Opened 14 years ago

Closed 14 years ago

#682 closed defect (duplicate)

Object with id: 3 was not of the specified subclass: net.sf.basedb.core.data.BioMaterialData (Discriminator: 16777216)

Reported by: base Owned by: everyone
Priority: trivial Milestone:
Component: core Version: 2.3.2
Keywords: Discriminator, BioMaterialData? Cc:

Description

Hi! After BASE2 first start i loaded some plugin for Affy (RMA e PLIER), then I import some Reporters and Array designs. Till then all was OK. Then I tried to create a Biosource and all seemed OK but when I push on View-AllItems? I had this message: Object with id: 3 was not of the specified subclass: net.sf.basedb.core.data.BioMaterialData? (Discriminator: 16777216)

When I checked the BioMaterials? table in MYSQL all seemed Ok and Discriminator is "1" like it should be.

I used first Base 2.3.1 but after this problem I upgrated to 2.3.2 but this not solved the problem.

I use Fedora 7 with java: java version "1.5.0_12" Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_12-b04) Java HotSpot?(TM) Client VM (build 1.5.0_12-b04, mixed mode, sharing) Mozilla Firefox 2.0.0.4, tomcat 5.5.23 and MySQL 5.0.37.

Thanks, Pietro

Change History (1)

comment:1 Changed 14 years ago by Nicklas Nordborg

Priority: blockertrivial
Resolution: duplicate
Status: newclosed

Duplicate of #509.

This is a problem with MySQL. You have the following options:

1) Wait for BASE 2.4 which includes an updated JDBC driver that fixes the problem (see #568) 2) Use a MySQL version lower than 5.0.27 3) Remove the useCursorFetch=true from the db.url setting in base.config

Note that 3) may cause BASE to use a lot of memory since data can't be streamed from the database but has to be loaded into memory.

Note: See TracTickets for help on using tickets.