Opened 14 years ago

Closed 14 years ago

#694 closed defect (fixed)

Creating a new plate event generates an exception

Reported by: Nicklas Nordborg Owned by: everyone
Priority: major Milestone: BASE 2.4
Component: web Version:
Keywords: Cc:

Description

I've got a confusing error after I made a merge of plates. I actually selected the plate I created during the merge and clicked on "Events" and further on "New" and a long error message occours in the popup window.

See the error message:

=======================================================================================

Unexpected error
BaseException on page /base2/lims/plates/events/edit_event.jsp
	
Version 	BASE 2.3.0 (build #3429; schema #30)
Web server 	Apache Tomcat/6.0.13
Database Dialect 	org.hibernate.dialect.MySQLInnoDBDialect
JDBC Driver 	com.mysql.jdbc.Driver (version 5.0)
Java runtime 	Java(TM) SE Runtime Environment (1.6.0_01-b06), Sun Microsystems Inc.
Operating system 	Linux i386 2.6.18-4-686
Memory 	Total: 35.3 MB
Free: 7.6 MB
Max: 481.5 MB
Browser 	Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.4) Gecko/20070508 Iceweasel/2.0.0.4 (Debian-2.0.0.4-0etch1)
Error message 	with clause can only reference columns in the driving table [SELECT pet FROM net.sf.basedb.core.data.PlateEventTypeData pet LEFT JOIN pet.plateEvents event WITH (event.plate = 10) WHERE (pet.plateType = 4) AND (event IS NULL) ORDER BY pet.ordinal ASC]

Stack trace

...at HibernateUtil.createQuery(HibernateUtil.java:1253)
...at AbstractEntityQuery.getMainHqlQuery(AbstractEntityQuery.java:347)
...at ItemQuery.list(ItemQuery.java:92)
...at org.apache.jsp.lims.plates.events.edit_005fevent_jsp._jspService(edit_005fevent_jsp.java:166)
...at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
...at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:393)
...at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:320)

...at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:71)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
...at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
...at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
...at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
...at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
...at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
...at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:261)
...at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
...at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:581)
...at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
...at java.lang.Thread.run(Thread.java:619)

Caused by: org.hibernate.hql.ast.InvalidWithClauseException
...at org.hibernate.hql.ast.HqlSqlWalker$WithClauseVisitor.visit(HqlSqlWalker.java:387)
...at org.hibernate.hql.ast.util.NodeTraverser.visitDepthFirst(NodeTraverser.java:40)
...at org.hibernate.hql.ast.util.NodeTraverser.visitDepthFirst(NodeTraverser.java:41)
...at org.hibernate.hql.ast.util.NodeTraverser.traverseDepthFirst(NodeTraverser.java:33)
...at org.hibernate.hql.ast.HqlSqlWalker.handleWithFragment(HqlSqlWalker.java:334)
...at org.hibernate.hql.ast.HqlSqlWalker.createFromJoinElement(HqlSqlWalker.java:316)
...at org.hibernate.hql.antlr.HqlSqlBaseWalker.joinElement(HqlSqlBaseWalker.java:3275)
...at org.hibernate.hql.antlr.HqlSqlBaseWalker.fromElement(HqlSqlBaseWalker.java:3067)
...at org.hibernate.hql.antlr.HqlSqlBaseWalker.fromElementList(HqlSqlBaseWalker.java:2945)
...at org.hibernate.hql.antlr.HqlSqlBaseWalker.fromClause(HqlSqlBaseWalker.java:688)
...at org.hibernate.hql.antlr.HqlSqlBaseWalker.query(HqlSqlBaseWalker.java:544)
...at org.hibernate.hql.antlr.HqlSqlBaseWalker.selectStatement(HqlSqlBaseWalker.java:281)
...at org.hibernate.hql.antlr.HqlSqlBaseWalker.statement(HqlSqlBaseWalker.java:229)
...at org.hibernate.hql.ast.QueryTranslatorImpl.analyze(QueryTranslatorImpl.java:228)
...at org.hibernate.hql.ast.QueryTranslatorImpl.doCompile(QueryTranslatorImpl.java:160)
...at org.hibernate.hql.ast.QueryTranslatorImpl.compile(QueryTranslatorImpl.java:111)
...at org.hibernate.engine.query.HQLQueryPlan.(HQLQueryPlan.java:77)
...at org.hibernate.engine.query.HQLQueryPlan.(HQLQueryPlan.java:56)
...at org.hibernate.engine.query.QueryPlanCache.getHQLQueryPlan(QueryPlanCache.java:72)
...at org.hibernate.impl.AbstractSessionImpl.getHQLQueryPlan(AbstractSessionImpl.java:133)
...at org.hibernate.impl.AbstractSessionImpl.createQuery(AbstractSessionImpl.java:112)
...at org.hibernate.impl.SessionImpl.createQuery(SessionImpl.java:1623)
...at HibernateUtil.createQuery(HibernateUtil.java:1249)
...at AbstractEntityQuery.getMainHqlQuery(AbstractEntityQuery.java:347)
...at ItemQuery.list(ItemQuery.java:92)
...at org.apache.jsp.lims.plates.events.edit_005fevent_jsp._jspService(edit_005fevent_jsp.java:166)
...at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
...at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:393)
...at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:320)
...at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:71)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
...at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
...at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
...at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
...at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
...at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
...at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:261)
...at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
...at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:581)
...at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
...at java.lang.Thread.run(Thread.java:619)

Change History (1)

comment:1 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [3595]) Fixes #694: Creating a new plate event generates an exception

Note: See TracTickets for help on using tickets.