Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#711 closed defect (duplicate)

Deleting a bioassayset doesn't decrease used quota as much as expected

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: BASE 2.4
Component: core Version:
Keywords: Cc:

Description

  1. I started out with a new fresh experiment. It used 0 bytes.
  2. A couple of raw bioassays was added to it and a root bioassayset was created. Now it used 120kb
  3. I deleted the root bioassayset and transformation (also from the trashcan), leaving the experiment with no analysed data. It still reports 60kb used

Change History (4)

comment:1 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Priority: minorcritical
Status: newassigned

I have made some initial checks and the problem seems to be unrelated to the deletions. It is instead the creation that adds to many bytes. In fact, it seems like it adds the correct number of bytes two times. This means that probably all existing experiments have a too high value for the number of bytes. This must be recalculated by the update script. We must also find out why the number of bytes are updated twice. By debug output I have found that Experiment.onBeforeCommit() are called twice from the same place in DbControl?.commit(). Here is the stacktrace:

java.lang.Throwable: adding bytes to experiment: 61498
  at net.sf.basedb.core.Experiment.onBeforeCommit(Experiment.java:244)
  at net.sf.basedb.core.DbControl.commit(DbControl.java:365)
  at net.sf.basedb.plugins.IntensityCalculatorPlugin.run(IntensityCalculatorPlugin.java:261)
  at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:88)
  at net.sf.basedb.core.InternalJobQueue$JobRunner.run(InternalJobQueue.java:420)
  at java.lang.Thread.run(Thread.java:619)

comment:2 Changed 14 years ago by Nicklas Nordborg

Resolution: duplicate
Status: assignedclosed

Duplicate of #712

comment:3 Changed 14 years ago by Nicklas Nordborg

The good news is that the problem with the experiment beeing updated twice was introduced by the fix to ticket #692. Since this has not yet been released we don't need an update script that corrects the existing byte count on the experiments.

comment:4 Changed 14 years ago by Nicklas Nordborg

(In [3629]) Fixes #712, References #711

Note: See TracTickets for help on using tickets.