Opened 14 years ago

Closed 14 years ago

#734 closed defect (duplicate)

Un-caught NullPointerException in plugin configurations list view.

Reported by: base Owned by: everyone
Priority: major Milestone:
Component: web Version:
Keywords: Cc:

Description

As an admin user I can create and view plugin configurations fine.

As a normal user, the plugin configurations list says: "23 hits" but the rest of the page is empty and the following is in catalina.out

14:27:07,922 ERROR [jsp]:253 - Servlet.service() for servlet jsp threw exception
java.lang.NullPointerException
        at net.sf.basedb.clients.web.util.NameablePluginAdaptor.getName(NameablePluginAdaptor.java:62)
        at net.sf.basedb.clients.web.Base.getLinkedName(Base.java:1120)
        at org.apache.jsp.admin.pluginconfigurations.list_005fconfigurations_jsp._jspService(list_005fconfigurations_jsp.java:
1076)
        at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
        at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:334)
        at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
        at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:72)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)

I'm on BASE 2.4.0 and can't say if this was a problem before or not (still exploring...). JDK 1.6.0

As this user I can view individual configurations just fine (by navigating from the plugin definition).

cheers, Bob.

Change History (1)

comment:1 Changed 14 years ago by Jari Häkkinen

Resolution: duplicate
Status: newclosed

Duplicate of ticket:753

Note: See TracTickets for help on using tickets.