Opened 14 years ago

Closed 14 years ago

#745 closed defect (fixed)

NullPointerException in File.getSize()

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.4.1
Component: core Version:
Keywords: Cc:

Description

I get a NullPointerException? in File.getSize() after a migration with quickTransfer set to true. Seems to be caused by not checking if a file has been uploaded or not. Here is the stacktrace:

java.lang.NullPointerException
  at net.sf.basedb.core.File.getAbsolutePath(File.java:1034)
  at net.sf.basedb.core.File.getSize(File.java:623)
  at org.apache.jsp.filemanager.files.list_005ffiles_jsp._jspService(list_005ffiles_jsp.java:1752)

Change History (2)

comment:1 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [3710]) Fixes #745: NullPointerException? in File.getSize() References #628 and #575.

Note: See TracTickets for help on using tickets.