Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#747 closed defect (invalid)

Problem trying to install RMAExpress plugin on Windows

Reported by: base Owned by: everyone
Priority: minor Milestone:
Component: install Version: 2.4.0
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

java.lang.ClassFormatError? on page /base2/admin/plugindefinitions/index.jsp

Version  	BASE 2.4.0 (build #3693; schema #40)
Web server 	Apache Tomcat/6.0.14
Database Server 	PostgreSQL 8.2.4
Database Dialect 	org.hibernate.dialect.PostgreSQLDialect
JDBC Driver 	org.postgresql.Driver (version 8.1)
Java runtime 	Java(TM) 2 Runtime Environment, Standard Edition (1.5.0-b64), Sun Microsystems Inc.
Operating system 	Windows XP x86 5.1
Memory 	Total: 58.4 MB
Free: 28.1 MB
Max: 63.6 MB
Browser 	Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Error message 	Unknown constant tag 0 in class file se/lu/thep/affymetrix/RMAExpress
Stack trace 	

...at java.lang.ClassLoader.defineClass1(Native Method)
...at java.lang.ClassLoader.defineClass(Unknown Source)
...at java.lang.ClassLoader.defineClass(Unknown Source)
...at net.sf.basedb.util.JarClassLoader.findClass(JarClassLoader.java:207)
...at java.lang.ClassLoader.loadClass(Unknown Source)
...at java.lang.ClassLoader.loadClass(Unknown Source)
...at PluginDefinition.newInstance(PluginDefinition.java:978)
...at PluginDefinition.loadPluginInformation(PluginDefinition.java:1088)

...at PluginDefinition.getNew(PluginDefinition.java:142)
...at org.apache.jsp.admin.plugindefinitions.index_jsp._jspService(index_jsp.java:172)
...at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
...at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:393)
...at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:320)
...at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:72)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
...at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
...at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
...at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
...at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
...at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
...at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:263)
...at org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:852)
...at org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:584)
...at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1508)
...at java.lang.Thread.run(Unknown Source)

Change History (3)

comment:1 Changed 14 years ago by base

jessepaquette@…

I hope this is what I was supposed to do. I'm going to post this to the mailing list, too.

Jesse

comment:2 Changed 14 years ago by Nicklas Nordborg

Description: modified (diff)
Resolution: invalid
Status: newclosed

I think I have seen this before... It was a long time ago (before BASE 2.0 was released) and was caused by a bug in one of the early Java 1.5 version. It was fixed in update 4 or 5 or something. Can you try upgrading to the latest Java 1.5 (update 12)?

comment:3 Changed 14 years ago by Nicklas Nordborg

...or you could also use 1.6...

Note: See TracTickets for help on using tickets.