Opened 14 years ago

Closed 14 years ago

#751 closed defect (invalid)

Fail to delete item from table view

Reported by: Johan Vallon-Christersson Owned by: everyone
Priority: minor Milestone: BASE 2.4.4
Component: web Version:
Keywords: Cc:

Description

When in table view an item is marked (by check box). Selecting delete fails to delete item. When item is viewed separately (i.e. first opened) it can be deleted. Have observed this defect in Sample table and Raw bioassays table.

Change History (6)

comment:1 Changed 14 years ago by Nicklas Nordborg

Any error messages? It works fine when I try it.

comment:2 in reply to:  1 Changed 14 years ago by Johan Vallon-Christersson

Replying to nicklas:

Any error messages? It works fine when I try it.

No error messages. Reproduced the problem in tables; Samples, Extracts, Labeled extracts, Lables, Hybridizations, and Scans. However, now it did work for Raw bioassays. When the problem occurs the page fail to refresh automatically. Does that provide any clue? Browser specific problem? I'm running Firefox 2.0.0.6 on Mac.

comment:3 Changed 14 years ago by Nicklas Nordborg

If the page doesn't refresh, there is probably some error somewhere. Please check the Tomcat log file and make sure that JavaScript? errors are displayed. Ie. with Firefox open the window: Tools -> Error console.

comment:4 Changed 14 years ago by Jari Häkkinen

Milestone: BASE 2.4.2

comment:5 Changed 14 years ago by Jari Häkkinen

This might be a problem due to very heavy load on mysql/tomcat during migration. Most of the RAM is eaten by the migration processes and maybe the server process gets affected. The tomcat log shows this message when the failure occurs:

Sep 17, 2007 2:53:09 PM org.apache.jk.core.MsgContext action
WARNING: Error sending end packet
java.net.SocketException: Broken pipe
        at java.net.SocketOutputStream.socketWrite0(Native Method)
        at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92)
        at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
        at org.apache.jk.common.ChannelSocket.send(ChannelSocket.java:531)
        at org.apache.jk.common.JkInputStream.endMessage(JkInputStream.java:112)
        at org.apache.jk.core.MsgContext.action(MsgContext.java:293)
        at org.apache.coyote.Response.action(Response.java:182)
        at org.apache.coyote.Response.finish(Response.java:304)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:204)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:282)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:767)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.jav
a:697)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocke
t.java:889)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPo
ol.java:684)
        at java.lang.Thread.run(Thread.java:595)
Sep 17, 2007 2:53:09 PM org.apache.jk.common.ChannelSocket processConnection
WARNING: processCallbacks status 2

The client machine shows the below message in a console window:

Warning: Unknown property 'align'.  Declaration dropped.
Source File: 
http://base2.thep.lu.se/demo/biomaterials/labeledextracts/list_labeledextrac
ts.jsp?ID=97d0e9a0d1233cdd
Line: 0

We'll test again after the migration is finished. If the problem goes away we probably need to test single server machine under heavy load to see if we can reproduce the problem.

comment:6 Changed 14 years ago by Nicklas Nordborg

Resolution: invalid
Status: newclosed

Seems to have been caused by Tomcat being overloaded.

Note: See TracTickets for help on using tickets.