Opened 14 years ago

Closed 14 years ago

#752 closed defect (fixed)

Configuration parameters not preserved when Plugin configuration copied

Reported by: Johan Vallon-Christersson Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.4.2
Component: web Version: 2.4.1
Keywords: Cc:

Description

When creating a new Plugin configuration by copying an existing configuration the parameters are not preserved. For example, by creating a copy of a configuration for the Raw data importer Max data columns is changed (from 48 in the original to 43 in the copy). Also, several column mappings are changed, e.g., from \F532 % Sat.\ in the original to \25\ in the copy.

Change History (8)

comment:1 Changed 14 years ago by Nicklas Nordborg

This sounds like you have mixed up your configurations. I am not able to reproduce this problem. Please check that you are actually comparing the original with the copy.

comment:2 in reply to:  1 Changed 14 years ago by Johan Vallon-Christersson

Replying to nicklas:

This sounds like you have mixed up your configurations. I am not able to reproduce this problem. Please check that you are actually comparing the original with the copy.

I manage to reproduce it (yesterday and today). Working on the demo site. The original "Gene Pix (ch1=Cy3, ch2=Cy5) (Pro 4.1.1.4)" with maxDataColumns = 48 and the created copy "BUG test Copy of Gene Pix (ch1=Cy3, ch2=Cy5) (Pro 4.1.1.4)" with maxDataColumns = 43.

comment:3 Changed 14 years ago by Johan Vallon-Christersson

Enell suggests that it might be a problem with version handling, .i.e., information from an old version is copied rather than from the current.

comment:4 Changed 14 years ago by Nicklas Nordborg

Please provide step-by-step instruction about how to reproduce this. Assume an empty database and start with creating the first configuration (that is later to be copied).

comment:5 Changed 14 years ago by Jari Häkkinen

Milestone: BASE 2.4.2

comment:6 Changed 14 years ago by Johan Enell

Version: 2.4.1
  • Create a plugin configuration
  • Edit your configuration
  • Copy your configuration and note that the parameter that you just edited has the value of the first configuration

comment:7 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:8 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [3745]) Fixes #752: Configuration parameters not preserved when Plugin configuration copied

Note: See TracTickets for help on using tickets.