Opened 14 years ago

Closed 14 years ago

#829 closed defect (fixed)

Item not found: Annotation[new]

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.5
Component: core Version:
Keywords: Cc:

Description

The following error message is displayed when annotating an item and doing the following:

  1. Enter a value for an annotation that doesn't previously have a value
  2. Remove the value
  3. Save

The stracktrace is available in the Tomcat error log:

net.sf.basedb.core.ItemNotFoundException: Item not found: Annotation[new]
  at net.sf.basedb.core.DbControl.deleteItem(DbControl.java:922)
  at net.sf.basedb.core.AnnotationSet.removeAnnotation(AnnotationSet.java:435)
  at net.sf.basedb.clients.web.Base.updateAnnotations(Base.java:1075)
  at org.apache.jsp.admin.pluginconfigurations.index_jsp._jspService(index_jsp.java:191)
...

The problem is that the JSP sends a "remove annotation" request for the annotation because of step 2. Since it didn't exist in the first place this should simply be ignored by the core.

Change History (2)

comment:1 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [3980]) Fixes #829: Item not found: Annotation[new]

Note: See TracTickets for help on using tickets.