Opened 14 years ago

Closed 14 years ago

#833 closed defect (fixed)

Removing items in the analysis tree

Reported by: Johan Enell Owned by: Nicklas Nordborg
Priority: trivial Milestone: BASE 2.5
Component: web Version: 2.4.6
Keywords: Cc:

Description

I've seen this bug occur before but I haven't reported it since I thought it was browser specific and I use Safari... Now I'm not so sure that it is browser specific. Anyway.

The bug occurs when I'm in the analysis tree of an experiment and I have "highlighted" one item in the tree so the properties are shown above the tree. I want to remove something in the tree but not the item that have been selected so I uncheck the highlighted item and selects the item I want to remove. What happens is that the highlighted item will be marked att removed even thou I unchecked it in the tree.

Change History (2)

comment:1 Changed 14 years ago by Nicklas Nordborg

Milestone: BASE 2.6BASE 2.5
Priority: majortrivial
Status: newassigned

It is not a browser related issue. The bug is caused by lines 503-508 in Base.java, which automatically set the current item as selected. This is normally not a problem since most pages doesn't mix a single-item view with a list.

comment:2 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [3986]) Fixes #833: Removing items in the analysis tree

Note: See TracTickets for help on using tickets.