Opened 14 years ago

Closed 14 years ago

#859 closed defect (fixed)

Downloading file from web services fails if the filename in BASE starts with a number

Reported by: Martin Svensson Owned by: Martin Svensson
Priority: critical Milestone: BASE 2.5
Component: webservices Version: trunk
Keywords: Cc:

Description (last modified by Martin Svensson)

This is probably because the file name is used as an element name in the message.

The exception thrown on the client side looks like this:

org.apache.axiom.om.OMException: com.ctc.wstx.exc.WstxUnexpectedCharException: Unexpected character '2' (code 50) in content after '<' (malformed start element?).
 at [row,col {unknown-source}]: [1,217]
        at org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:239)
        at org.apache.axiom.om.impl.llom.OMElementImpl.buildNext(OMElementImpl.java:552)
        at org.apache.axiom.om.impl.llom.OMElementImpl.getFirstOMChild(OMElementImpl.java:563)
        at org.apache.axiom.om.impl.llom.OMElementImpl.getFirstElement(OMElementImpl.java:823)
        at net.sf.basedb.ws.client.AbstractRPCClient.invokeFileBlocking(AbstractRPCClient.java:80)
        at net.sf.basedb.ws.client.RawBioAssayClient.downloadRawDataByType(RawBioAssayClient.java:125)
        at TestWebservices.test_getRawDataInExperiment(TestWebservices.java:416)
        at TestWebservices.test_all(TestWebservices.java:147)
        at TestWebservices.main(TestWebservices.java:80)
Caused by: com.ctc.wstx.exc.WstxUnexpectedCharException: Unexpected character '2' (code 50) in content after '<' (malformed start element?).
 at [row,col {unknown-source}]: [1,217]
        at com.ctc.wstx.sr.StreamScanner.throwUnexpectedChar(StreamScanner.java:623)
        at com.ctc.wstx.sr.BasicStreamReader.nextFromTree(BasicStreamReader.java:2852)
        at com.ctc.wstx.sr.BasicStreamReader.next(BasicStreamReader.java:1019)
        at org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:153)
        ... 8 more

Change History (2)

comment:1 Changed 14 years ago by Martin Svensson

Description: modified (diff)
Status: newassigned

comment:2 Changed 14 years ago by Martin Svensson

Resolution: fixed
Status: assignedclosed

(In [4033]) Fixes #859 Downloading file from web services fails if the filename in BASE starts with a number. A test is set up with a cel file in TestWebservices?.

Note: See TracTickets for help on using tickets.