Opened 14 years ago

Closed 14 years ago

#959 closed defect (fixed)

Users may be duplicated in group member list for quota groups

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 2.6.2
Component: core Version:
Keywords: Cc:

Description

How to reproduce:

  1. Create two groups, A and B. Assign quota to one of the groups, say A.
  2. Create a user account and select group A as the quota group. Also, make the user a member of both groups.
  3. Go to the single-item view page for the A group. The user is listed twice.

Creating more groups and adding the user as a member to those groups will make the user appear even more time in the membership list for group A.

I have checked the code and it looks like the query generated by Group.getUsers() isn't correct. The problem is with the two LEFT JOIN:s to the Groups table.

Change History (2)

comment:1 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4199]) Fixes #959: Users may be duplicated in group member list for quota groups

Note: See TracTickets for help on using tickets.