Opened 15 years ago

Closed 14 years ago

#968 closed enhancement (fixed)

Raw data importer – Enhance feature mismatch error handling

Reported by: Johan Vallon-Christersson Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.7
Component: coreplugins Version:
Keywords: Cc:

Description

Feature mismatch error handling when importing raw data concerns how to handle errors that are caused by the data (in the source file) not matching the feature on the array design (in BASE). Invalid block or spot coordinates, or a mismatch on reporter for a specific feature when matching array design and source file, can for example cause errors. Current alternative actions when feature mismatch error are encountered include:
skip = Skip the current data line and continue
fail = Stop with an error message

However, it would be useful to handle some specific mismatch cases separately. Typically, data in the source file can include coordinates (features) that do not exist on the array design. This can for example be the effect of image analysis software completing row/column coordinates in blocks that lack a few features in the last row. Another example is array designs that include features that lack reporter due to non-existing or empty source wells (from printing arrays).

In these instances there will be a feature mismatch error either because a feature exists in the source file but not in the array design, or because a feature has reporter ‘’ (null/missing) in the array design but some alias in the source file, e.g., NULL, empty, or missing.

A new alternative action should be added for feature mismatch error and that would handle the described scenarios above yet give an error if a “true” mismatch would occur, e.g., completely different reporters for the same feature. The new alternative action could allow the following (but fail when other mismatches are encountered):

  1. If features in the source file are matched against the array design (in BASE) and BASE returns the ‘’ (null/missing) reporter for that feature, the data from the source file for that feature should be imported. The number of occasions this occurs should be tracked and outputted, i.e., number of spots imported with ‘’ reporter in array design.
  1. If features in the source file are matched against the array design (in BASE) and BASE returns that the feature does not exist for the array design the current data line should be skipped. The number of occasions this occurs should be tracked and outputted, i.e., number of spots skipped due to missing feature in array design.

Change History (3)

comment:1 Changed 14 years ago by Nicklas Nordborg

Milestone: BASE 2.7

comment:2 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:3 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4246]) Fixes #968: Raw data importer ?\226?\128?\147 Enhance feature mismatch error handling

Note: See TracTickets for help on using tickets.