Opened 14 years ago

Closed 14 years ago

#970 closed defect (fixed)

PluginConfigurationImporter doesn't support multi-valued parameters

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.6.2
Component: coreplugins Version:
Keywords: Cc:

Description

From the mailing list: http://www.mail-archive.com/basedb-devel@lists.sourceforge.net/msg00295.html

The PCExporter seems to work fine and the parameter info in the xml file looks as in the example below (N parameter values in this example).

 <parameter>
   <name>paramName</name>
   <label>paramLabel</label>
   <description>paramDesc</description>
   <class>java.lang.String</class>
   <value>paramValue1</value>
   <value>paramValue2</value>
   ...
   <value>paramValueN</value>
 </parameter>

Stacktrace:

net.sf.basedb.core.BaseException: Found N values in parameter 'paramName'. Only 1 is allowed.
at net.sf.basedb.plugins.PluginConfigurationImporter.doImport(PluginConfigurationImporter.java:340)
at net.sf.basedb.plugins.PluginConfigurationImporter.run(PluginConfigurationImporter.java:226)
at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:89)
at net.sf.basedb.core.InternalJobQueue$JobRunner.run(InternalJobQueue.java:421)
at java.lang.Thread.run(Thread.java:613)
Caused by: net.sf.basedb.core.InvalidDataException: Found N values in parameter 'paramName'. Only 1 is allowed.
at net.sf.basedb.core.ParameterType.validate(ParameterType.java:248)
at net.sf.basedb.core.PluginConfiguration.setParameterValuesInternal(PluginConfiguration.java:462)
at net.sf.basedb.core.PluginConfiguration.setParameterValues(PluginConfiguration.java:430)
at net.sf.basedb.plugins.PluginConfigurationImporter.setPluginConf(PluginConfigurationImporter.java:460)
at net.sf.basedb.plugins.PluginConfigurationImporter.doImport(PluginConfigurationImporter.java:334)

Attachments (1)

norm.export.xml (4.4 KB) - added by base 14 years ago.

Download all attachments as: .zip

Change History (3)

Changed 14 years ago by base

Attachment: norm.export.xml added

comment:1 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4211]) Fixes #970: PluginConfigurationImporter? doesn't support multi-valued parameters

Note: See TracTickets for help on using tickets.