source: plugins/base1/se.lu.onk.ReplicateError/trunk/README @ 774

Last change on this file since 774 was 774, checked in by Jari Häkkinen, 14 years ago

References #129.

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
  • Property svn:mime-type set to text/x-trac-wiki
File size: 5.4 KB

$Id: README 774 2008-09-18 17:16:54Z jari $

About se.lu.onk.ReplicateError

The se.lu.onk.ReplicateError plug-in for BASE is

se.lu.onk.ReplicateError is free software. See the file license.txt for copying conditions.

The package was created by Johan Enell and is currently maintained by Jari Häkkinen.

Downloading

se.lu.onk.ReplicateError can be obtained from

http://baseplugins.thep.lu.se/wiki/PluginDownload

Installation and upgrade

This plug-in is only tested in BASE 2.8 through the Base1PluginExecuter but is expected to work also in BASE 1.2.17. Please report failure or success in BASE 1.2 through http://baseplugins.thep.lu.se. These installation instructions only describe how to get the plug-in to work with the Base1PluginExecuter in the latest BASE version 2. BASE 1.2 installers should enable one line in files AAtabs.html and WAtabs.html, read the information in these short files.

If you downloaded a binary package you only need to follow these instructions. If you prefer to compile the package yourself, read the instructions about compiling and creating a distribution before doing the installation steps described here.

You need to understand how to install plug-ins in BASE, please refer to BASE documentation at http://base.thep.lu.se for general instructions on plug-in installation. The BASE documentation contains a chapter on plug-ins. If you have read the plug-in information you should be able to follow this path

  # cd /path/to/base/plugins
  # download ReplicateError-version.tgz
  # untar ReplicateError-version.tgz
  # ln -s ReplicateError-version ReplicateError

The symbolic link in the last line above allows for easier change to future version of the plug-in.

  # Log in to your BASE as admin
  # Upload the configuration files `pluginConfigurationAA.base` and
    `pluginConfigurationWA.base`.
  # Create/update one configuration each for across and within assays
    mode of the ReplciateError plug-in where you select the plug-in
    defintion files `pluginConfigurationAA.base` and
    `pluginConfigurationWA.base`, respectively. BASE will respond that
    plug-ins where configured but ...
  # Re-configure the plug-ins without selecting a file, set the
    `Plugin executables path` and proceed to next window by clicking
    `Next`. This is explained in the BASE documentation and needs to
    be done even when you update your plug-in.
  # In this parameter window set the `Name of executable`. The value
    of this parameter and `Plugin executables path` should add up to
    the absolute path to the binaries `runAA` and `runWA`, i.e.,
    /path/to/base/plugins/ReplicateError/runAA. How this string looks
    like depends on your plug-in directory structure.
  # Test the plug-ins and when you are satisfied, share it to your
    users.

Compiling

You must checkout the se.lu.onk.ReplicateError from the repository, follow the instructions below. Then download and untar the se.lu.onk.BaseFile package available from http://baseplugins.thep.lu.se/wiki/PluginDownload. This package is known to work with se.lu.onk.BaseFile version 1.0.

  check out project, see instructions below
  # cd /path/to/se.lu.onk.ReplicateError
  # wget http://baseplugins.thep.lu.se/.../BaseFile-1.0.tgz
  # wget http://baseplugins.thep.lu.se/.../BaseFile-1.0.tgz.MD5
	# optionally compare the MD5 sum of the downloaded file and the MD5-file
  # tar zxpf BaseFile-1.0.tgz
  # ln -s BaseFile-1.0 BaseFile
    or
  # mv BaseFile-1.0 BaseFile

It is important that the BaseFile package is located in directory BaseFile. Now simple issue ant. This will create a jar file dist/ReplicateError.jar.

Creating a distribution

Update the version number in build.xml, and issue `ant package`. This creates a distribution package with all required components, including BaseFile?.jar and associated files.

Bug Reporting

You can report se.lu.onk.ReplicateError bugs on

http://baseplugins.thep.lu.se/newticket

Use user base and password base.

Subversion Access

The se.lu.onk.ReplicateError source repository is available via anonymous subversion access, issue:

svn co http://baseplugins.thep.lu.se/svn/plugins/base1/se.lu.onk.ReplicateError/trunk se.lu.onk.ReplicateError

There is no guarantees about the contents or quality of the latest code in the subversion repository: it is not unheard of for code that is known to be broken to be committed to the repository. Use at your own risk. You may prefer to check out a released version instead, then replace trunk with tags/version in the above example.


Copyright (C) 2008 Jari Häkkinen
This file is part of the se.lu.onk.ReplicateError plug-in for
BASE. Available at http://baseplugins.thep.lu.se/ and BASE web site is
http://base.thep.lu.se
This is free software; you can redistribute it and/or modify it under
the terms of the GNU General Public License as published by the Free
Software Foundation; either version 3 of the License, or (at your
option) any later version.
This package is distributed in the hope that it will be useful, but
WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
General Public License for more details.
You should have received a copy of the GNU General Public License
along with this package. If not, see <http://www.gnu.org/licenses/>.
Note: See TracBrowser for help on using the repository browser.