Changeset 272


Ignore:
Timestamp:
May 21, 2007, 5:57:41 PM (16 years ago)
Author:
Peter Johansson
Message:

intermediate commit of new installation instructions for affymetrix package refs #45

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/se/lu/thep/affymetrix/INSTALL

    • Property svn:mime-type set to text/x-trac-wiki
    r228 r272  
    11$Id$
    22
    3 ======================================================================
     3----------------------------------------------------------------------
     4{{{
    45Copyright (C) 2006 Jari Häkkinen
    5 
    6 This file is part of RMAExpress plug-in for BASE,
    7 http://baseplugins.thep.lu.se/wiki/thep.lu.se.RMAExpress
    8 
    9 RMAExpress plug-in for BASE is free software; you can redistribute it
    10 and/or modify it under the terms of the GNU General Public License as
    11 published by the Free Software Foundation; either version 2 of the
    12 License, or (at your option) any later version.
    13 
    14 RMAExpress plug-in for BASE is distributed in the hope that it will be
    15 useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
    16 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    17 General Public License for more details.
     6Copyright (C) 2007 Peter Johansson
     7
     8This file is part of se.lu.thep.affymetrix package for BASE,
     9http://baseplugins.thep.lu.se/wiki/se.thep.lu.se.affymetrix
     10
     11se.lu.thep.affymetrix package for BASE is free software; you can
     12redistribute it and/or modify it under the terms of the GNU General
     13Public License as published by the Free Software Foundation; either
     14version 2 of the License, or (at your option) any later version.
     15
     16se.lu.thep.affymetrix package for BASE is distributed in the hope that
     17it will be useful, but WITHOUT ANY WARRANTY; without even the implied
     18warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See
     19the GNU General Public License for more details.
    1820
    1921You should have received a copy of the GNU General Public License
     
    2123Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307,
    2224USA.
    23 ======================================================================
    24 
     25----------------------------------------------------------------------
     26
     27
     28= Installation Guide for se.lu.thep.affymetrix =
     29
     30This file contains installation information for two plugins: RMAExpress
     31and Plier.
    2532
    2633If you think these instructions are worthless or stupid or maybe both,
     
    2835to improve them. My email address is jari@thep.lu.se
    2936
    30 
    31 0. Introduction
    32 
    33 Short intro:
    34 
    35 The route for successful first time installation of this plug-in is
    36 a) Install the plug-in.
    37 b) Install wxWidgets.
    38 c) Install RMAExpressConsole.
    39 d) Make BASE aware of the new plug-in.
     37== 0. Introduction ==
     38
     39=== Short intro: ===
     40
     41The route for successful first time installation of this RMAExpress plugin is
     42  i. Install the plug-in.
     43  i. Install wxWidgets.
     44  i. Install RMAExpressConsole.
     45  i. Make BASE aware of the new plug-in.
     46
     47The route for successful first time installation of this Plier plugin is
     48  i. Install the plug-in.
     49  i. Install apt-probeset-summarize.
     50  i. Make BASE aware of the new plug-in.
    4051
    4152Upgrading the plug-in is even easier, see item 7) below.
    4253
    43 Longer intro:
    44 
    45 There are two supported ways to install the RMAExpress plug-in, you
     54=== Longer intro: ===
     55
     56There are two supported ways to install this affymetrix package, you
    4657either download a pre-compiled package or you checkout the latest
    4758source from the subversion repository. The below instructions covers
     
    5162supported, it is supplied for reference only.
    5263
    53 Note, the underlying RMAExpress algorithm itself is not a part of this
    54 package. This packages contains the plug-in code needed for hooking up
    55 RMAExpress to BASE as a plug-in. RMAExpress must be installed for this
    56 plug-in to work, see more in item 1.ii) below.
     64Note, the underlying algorithms RMA and Plier are not part of this
     65package. This package contains the plug-in code needed for hooking up
     66RMAExpress and Plier to BASE as a plug-in. The underlying binaries,
     67RMAExpress and Plier, must be installed for the corresponding plug-in
     68to work. See more in item 1.ii below.
    5769
    5870Users who prefer the install from pre-compiled packages must go
     
    6779
    6880
    69 1. Pre-requisites
    70 
    71 i) Pre-requisite for both all install options:
     81== 1. Pre-requisites ==
     82
     83i) Pre-requisite for both all install options: 
    7284This plug-in will only work with BASE 2.0 or later, i.e. BASE 1.2.x is
    7385not (and will never be) supported.
    7486
    75 ii) Pre-requisite for both binary package and subversion tree
    76 installs: Installation of RMAExpressConsole.
    77 
    78 RMAExpressConsole available in the RMAExpress package written by Ben
    79 Bolstad, and the official RMAExpress web site is
     87ii) Pre-requisite for RMAExpress plug-in (both binary package and
     88subversion tree installs): Installation of RMAExpressConsole.
     89
     90Pre-requisite for Plier plug-in (both binary package and
     91subversion tree installs): Installation of apt-probeset_summarize.
     92
     93RMAExpressConsole is available in the RMAExpress package written by
     94Ben Bolstad, and the official RMAExpress web site is
    8095http://rmaexpress.bmbolstad.com/
    8196
     
    88103interest here.
    89104
    90 You should install the RMAExpressConsole binary such that it is
    91 readable for the user running your BASE application server. The name
    92 of the binary MUST be 'RMAExpressConsole' and copied into the same
    93 directory as the plug-in (see item 3.v below). These two conditions
    94 are hard coded in the plug-in.
     105apt-probeset-summarize is available in the Affymetrix Power Tools
     106package available through Affymetrix home page
     107http://www.affymetrix.com/support/developer/powertools/index.affx
     108
     109You should install the binaries (RMAExpressConsole and
     110apt-probeset-summarize) such that it is readable for the user running
     111your BASE application server. The name of the binaries MUST be
     112`RMAExpressConsole` and `apt-probeset-summarize`, respectively. Also
     113binaries must be copied into the same directory as the plug-in (see
     114item 3.v below). These two conditions are hard coded in the plug-ins.
    95115
    96116Install of the BASE plug-in will succeed even if this requisite is not
Note: See TracChangeset for help on using the changeset viewer.