Changeset 282


Ignore:
Timestamp:
May 22, 2007, 1:45:15 PM (16 years ago)
Author:
Jari Häkkinen
Message:

Improved text.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/se/lu/thep/affymetrix/INSTALL

    r281 r282  
    8383
    8484=== RMAExpressConsole and apt-probeset-summarize ===
     85
     86''RMAExpressConsole''
     87
    8588Pre-requisite for RMAExpress plug-in (both binary package and
    8689subversion tree installs) is that RMAExpressConsole is installed.
    87 
    88 Pre-requisite for Plier plug-in (both binary package and
    89 subversion tree installs) is that apt-probeset_summarize is installed.
    9090
    9191RMAExpressConsole is available in the RMAExpress package written by
     
    9696wxWidgets (a.k.a. wxWindows) is installed on your system. wxWidgets is
    9797found at http://www.wxwidgets.org. The compilation of
    98 RMAExpressConsole is straightforward (at least on OpenSuSE 10.2 and
     98RMAExpressConsole is straightforward (at least on OpenSuSE 10.0 and
     9910.2, and
    99100MacOSX 10.4.9). Download the source for v1.0beta1 and unpack the tar
    100101file. Unfortunately the source will not work out of the box in some
     
    103104#include <cmath>
    104105}}}
    105 to `!RawDataVisualize.cpp' before issuing 'make'. After this patch
     106to `!RawDataVisualize.cpp` before issuing 'make'. After this patch
    106107RMAExpressConsole will be compiled (together with some other binaries
    107108which are of no interest here.
     109
     110''apt-probeset-summarize''
     111
     112Pre-requisite for Plier plug-in (both binary package and
     113subversion tree installs) is that apt-probeset_summarize is installed.
    108114
    109115apt-probeset-summarize is available in the Affymetrix Power Tools
     
    116122experienced some problems building APT and at the time being we have
    117123not succeeded.
     124
     125''Installation of binaries''
    118126
    119127You should install the binaries (RMAExpressConsole and
     
    128136
    129137=== Compile time access to BASE core jar file. ===
     138
    130139This is only needed for compilation and installition from a subversion
    131140tree, i.e., it is not needed when installing a pre-compiled package.
     
    203212== 4. BASE configuration ==
    204213
    205 === vi) Make BASE aware of the new plug-in ===
     214=== vi) Make BASE aware of the new plug-ins ===
     215
     216You need to perform the below steps for both plug-ins in this
     217package. Currently there is no way to install all plug-ins in one
     218package.
    206219
    207220 * Login to BASE with plug-in administrative privileges.
     
    210223
    211224 * Click on 'New...'. This will open up the 'Create plugin' pop-up
    212    window. Type "se.lu.thep.affymetrix.RMAExpress" in the 'Class'
     225   window. Type `se.lu.thep.affymetrix.RMAExpress` in the 'Class'
    213226   field and
    214    "<base-dir>/www/plugins/se/lu/thep/affymetrix/RMAExpress.jar" in
    215    the 'Path' field. Replace <base-dir> with whatever you used in item
    216    3.v) above. Click on the 'Save' button.
    217 
    218  * Share the plug-in to all users/roles/groups that should have
    219    access to it (sharing it to group Everyone should be sufficient in
    220    most cases).
    221 
     227   `/path/to/base/www/plugins/se/lu/thep/affymetrix/affymetrix.jar" in
     228   the 'Path' field. Obviously, if you have choosen another location
     229   for the jar above you should adapt to that. Click on the 'Save'
     230   button.
     231
     232 * Share the plug-in to all users/roles/groups that should have access
     233   to it (sharing it to group 'Everyone' should be sufficient in most
     234   cases).
     235
     236 * Redo the third and fourth step above for Plier.
    222237
    223238 * That's it, now you need to BASE skills to actually make use of the
    224    plug-in. Read the README file for some pointers on what to do now.
     239   plug-in.
    225240
    226241== 5. Updating a plug-in in BASE. ==
     
    232247
    233248Installing a new binary is trivial, just replace the old binary with
    234 the new binary.
     249the new binary. However, make sure that the input and output formats
     250has not changed.
    235251
    236252=== Update RMAExpress or Plier plug-ins for BASE ===
    237253
    238    This is straighforward:
     254This is straighforward:
    239255
    240256   - Replace the old jar-file and
     
    244260   - Choose 'Administrate' -> 'Plugins' -> 'Definitions'.
    245261
    246    - Locate the plug-in (RMAExpress or PLier) in the list and click on it.
     262   - Locate the plug-in (RMAExpress or Plier) in the list and click on it.
    247263
    248264   - Click on the 'Unload' button if it is available. This will
Note: See TracChangeset for help on using the changeset viewer.