Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#115 closed defect (invalid)

MeV launch returns a 'jsp' extension not a 'jnlp'

Reported by: Jari Häkkinen Owned by: Nicklas Nordborg
Priority: major Milestone:
Component: net.sf.basedb.mev Keywords:
Cc:

Description (last modified by Jari Häkkinen)

For Java web start the startup file have jnlp as extension, here it should be launch_mev.jnlp, to trigger start of Java. The current implementation of this extension returns a file launch_mev.jsp which starts my editor.

I am not sure if this a MeV problem or a BASE core problems so I have also reported this at the BASE ticket system (http://base.thep.lu.se/ticket/1044)

Change History (9)

comment:1 Changed 13 years ago by Jari Häkkinen

Description: modified (diff)

comment:2 Changed 13 years ago by Nicklas Nordborg

I think the problem is within your web browser. If configured correctly it should not trigger on file extensions, but on the content type returned by the web server. The content type is set to application/x-java-jnlp-file for that file. It is not possible to change the file extension since then Tomcat would not recognise it as a JSP file and it would give you the JSP source code instead of the JNLP XML file.

comment:3 Changed 13 years ago by Nicklas Nordborg

By the way, I don't think your browser triggers on JSP files, because, then you wouldn't be able to use BASE at all. It may just be that it doesn't know about the application/x-java-jnlp-file MIME type and reverts to some default behavior. Eg. opening the file in the editor. In Firefox you can handle this by going to: Edit -> Preferences -> Content -> File types [Manage...]

comment:4 Changed 13 years ago by Jari Häkkinen

My firefox preference says:

Java Web Start file
.jnlp, application/x-java-jnlp-file

and it is set to open the file with the default application. The default application is setup correctly on my mac:

signori:Desktop> open launch_mev.jsp 
signori:Desktop> mv launch_mev.jsp launch_mev.jnlp
signori:Desktop> open launch_mev.jnlp 

The launch_mev.jsp is the filename given to the jnlp file by default (causing my problems) when clicking on the BASE MeV button. The first open starts emacs, whereas the second fires Java. So, there is some issue ... removing the content type entry in my firefox preferences gives me a save dialog and suggests name launch_mev.jsp. Going to Safari ... works! It will download a file launch_mev.jsp.jnlp and start Java. Back to firefox, I'll return with more information.

comment:5 Changed 13 years ago by Jari Häkkinen

Resolution: invalid
Status: newclosed

I have no information on how to resolve this. Following hints on the web doesn't help me. My colleagues firefox browsers work (they also use macs) ... I tried to erase my mime settings ... create new defaults ... firefox always falls back on either save to disk or using defaut application for .jsp files. I'll give up firefox for now and start using Safari with BASE. Safari felt faster with BASE.

comment:6 Changed 13 years ago by Nicklas Nordborg

If I go to the dialog Edit -> Preferences -> Content -> File types [Manage...] I can find the JNLP file type in the list of registered types, select it and click on Change action. In the popup I can select three different options:

  • Open with default application
  • Open with this application: <path to some application>
  • Save them on my computer

I have selected the second option and selected the javaws application that comes with Java. It seems easy enough to switch between which option you want, so I have no idea why this doesn't work for you. The only thing I have been able to dig up is some advanced settings that seems to have something to do with it.

  1. Type about:config in the address window. Press enter.
  2. Type helperApps in the filter window.
  3. Three settings which seems related to this should show up.
  4. My values are:
    • ...alwaysAks.force=false,
    • ...neverAsk.openFile=
    • ...neverAsk.saveFile=

Eg. the last two options have no value.

comment:7 Changed 13 years ago by Jari Häkkinen

The problem is that the file is not recognized as a jnlp file by my firefox. I checked my settings and they match the ones you have. I removed my MIME stuff, clicked around other setting ... and I finally got firefox to ask me what I wanted to do with the .jsp file after clicking on the MeV button. I selected javaws and remember selection, and voila, MeV starts. Going back to check what changed in my settings shows that the application/x-java-jnlp-file MIME type is associated with .jsp extension! Anyhow, it works now.

comment:8 Changed 13 years ago by Jari Häkkinen

So, I cannot stop testing. I decided to edit the MIME type association, changed jsp to jnlp. The MeV button still works, a .jsp files is downloaded (with jnlp content), so clearly the MIME type is being used by firefox since it doesn't trigger on the jsp extension.

Something was wrong in my settings, it got fixed somehow. 10/4.

comment:9 Changed 12 years ago by Jari Häkkinen

Milestone: MEV Launcher v1.x
Note: See TracTickets for help on using tickets.