#1230 closed defect (fixed)

NullPointerException in the "Map external data" wizard

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v4.25.1
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

Stacktrace

java.lang.NullPointerException
    at java.base/java.util.TreeMap.put(TreeMap.java:561)
    at java.base/java.util.TreeSet.add(TreeSet.java:255)
    at net.sf.basedb.reggie.servlet.ExportServlet$ReleaseIdToPadConverter.convert(ExportServlet.java:1874)
    at net.sf.basedb.reggie.servlet.ExportServlet$ReleaseIdToPadConverter.convert(ExportServlet.java:1809)
    at net.sf.basedb.reggie.servlet.ExportServlet.doPost(ExportServlet.java:657)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:660)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:741) 
....

It seems to be triggered when re-mapping from a release id to personal number and PAD, by a case that has more than one specimen where at least one specimen is missing a PAD value.

The problem is that the TreeSet class (used for sorting unique PAD values) doesn't support null values. A TreeSet is used in other situations as well so we should check for more cases that may have a similar problem.

Change History (1)

comment:1 Changed 20 months ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

In 5853:

Fixes #1230: NullPointerException? in the "Map external data" wizard

Found 2 cases in the export wizard and 2 more cases in the relase exporter plug-in that could be triggered by a sequencer wihtout serial number or a demux without a read-string.

Note: See TracTickets for help on using tickets.