Opened 13 years ago

Closed 13 years ago

#133 closed enhancement (fixed)

ReplicateError: The plug-in adds new entries to the stdout.txt for reporters that had null values in stdin.txt

Reported by: Jari Häkkinen Owned by: Jari Häkkinen
Priority: major Milestone:
Component: onk.lu.se Keywords:
Cc:

Description (last modified by Jari Häkkinen)

This causes Base1PluginExecurter to import these reporters with null values to bioassays whereas it seems like BASE1 just ignores these lines. Rather than changing the behaviour of Base1PluginExecuter to skip such lines ReplicateError should not create these entries in stdout.txt.

The difference between BASE version 1 and 2 in this case is that BASE version 2 allows null values for intensities.

Change History (2)

comment:1 Changed 13 years ago by Jari Häkkinen

Description: modified (diff)
Owner: changed from Johan Enell to Jari Häkkinen
Status: newassigned

Now I have a better understanding of the issue. The problem is that in several cases one or more of the replicates has no defined value. The exported data is simply an empty field. In the ReplicateError plug-in these are used in computation and therefore generates a NaN that is printed to stdout.txt. BASE1 ignores NaNs? but BASE2 does not and stores them as null values. The resolution is to print an empty field rather than NaN, BASE2 will ignore these lines and hopefully BASE1 too. So, this fix is tested with Base1PluginExecuter in BASE2 but not tested in BASE1. It is expected to work also in BASE1.

comment:2 Changed 13 years ago by Jari Häkkinen

Resolution: fixed
Status: assignedclosed

(In [769]) Fixes #133. Read comment made to the ticket.

Note: See TracTickets for help on using tickets.