Opened 12 years ago

Closed 12 years ago

#732 closed (fixed)

Starting X!Tandem search crashes when trying to select a parameter set that is not on first table page

Reported by: olle Owned by: olle
Milestone: Proteios SE 2.15.0 Keywords:
Cc:

Description

Starting X!Tandem search crashes when trying to select a parameter set that is not on first table page (normally 20 sets are shown on a table page).

Change History (8)

comment:1 Changed 12 years ago by olle

Status: newassigned

Ticket accepted.

comment:2 Changed 12 years ago by olle

Discussion of problem.

  • Inspection of source code and log files for runs with added debug statements suggest that the problem is related to that in Ticket #719 (Project table scroller on Home page results in NullPointerException). However, in this case the X!Tandem parameter sets can be viewed and selected via the View -> Search Setup -> X!Tandem menu item, as the problem only occurs when trying to select the X!Tandem parameter set to use for search job. The latter functionality is managed by class UseSpectrumFileForXTandemSearchExtension.
  • Tests with applying the fix described in Ticket #719 for class ViewHome on class UseSpectrumFileForXTandemSearchExtension, revealed that although the program did not crash, the scroll action for the table page did not work (the same first page of search parameter sets was always shown), indicating that the page selection made in the table scroller section was not sent back to the class managing the table.

comment:3 Changed 12 years ago by olle

(In [4067]) Refs #732. Class/file action/file/UseSpectrumFileForXTandemSearchExtension.java in client/servlet/ updated to allow selection of an X!Tandem parameter set that is not on the first table page:

  1. Protected method void runMe() updated to table configuration action id to the id of the class itself, and inform the TableFactory instance about selected values for scroller variables.

comment:4 Changed 12 years ago by olle

(In [4069]) Refs #732. Class/file action/file/UseSpectrumFileForOMSSASearchExtension.java in client/servlet/ updated to allow selection of an OMSSA parameter set that is not on the first table page:

  1. Protected method void runMe() updated to set table configuration action id to the id of the class itself, and inform the TableFactory instance about selected values for scroller variables.

comment:5 Changed 12 years ago by olle

(In [4070]) Refs #732. Class/file action/mascot/SelectMascotParameterSetStorage.java in client/servlet/ updated to allow selection of a Mascot parameter set that is not on the first table page:

  1. Protected method void runMe() updated to set table configuration action id to the id of the class itself, and inform the TableFactory instance about selected values for scroller variables.

comment:6 Changed 12 years ago by olle

Design discussion.

  • Selection of a search parameter set for OMSSA and Mascot searches showed the same problem as observed for X!Tandem, when a parameter set should be selected that was not on the first table page. For OMSSA the problem appeared in class/file action/file/UseSpectrumFileForOMSSASearchExtension.java, that directly corresponds to the X!Tandem class/file action/file/UseSpectrumFileForXTandemSearchExtension.java, while for Mascot the problem appeared in class/file action/mascot/SelectMascotParameterSetStorage.java, due to an extra step with selection of search user data.

comment:7 Changed 12 years ago by olle

Design discussion.

  • Common to the cases discussed here, is that a selection from a table should be performed during a multi-step process ("wizard") in preparation for a task. When viewing a table of items, the table is often managed by classes TableFactory2/ConfigureTableFactory2, that allow advanced configuration and adds standard buttons for actions appropriate for the table. However, when the table should only be used for selecting items during a multi-step process, the extra features are normally not desired, and the table is therefore managed by class TableFactory instead. The latter class needs some extra configuration to support scrolling between table pages, which is what has been added in the fixes in this ticket.

comment:8 Changed 12 years ago by olle

Resolution: fixed
Status: assignedclosed

The ticket is closed, as the desired functionality has been added. Should problems with the current solution appear, this ticket may be reopened, or a new ticket created.

Note: See TracTickets for help on using tickets.