Opened 10 years ago

Closed 9 years ago

#783 closed (fixed)

Table preferences job table

Reported by: marianne Owned by: olle
Milestone: Proteios SE 2.18.0 Keywords:
Cc:

Description

Setting table preferences to "always" works for certain tables such as the hits table, but not for e.g. the job table. For the job table the preferences are saved only during the session.

Change History (6)

comment:1 Changed 10 years ago by Fredrik Levander

Milestone: Proteios SE Future ReleaseProteios SE 2.18.0
Owner: set to olle

comment:2 Changed 10 years ago by olle

Status: newassigned

Ticket accepted.

comment:3 Changed 10 years ago by olle

Problem discussion.

Tests were performed on Proteios SE installed on an openSUSE 12.2 system, and there changed preferences for the job table, such as what columns to show and in what order, were saved from one session to another. The reported problem therefore couldn't be reproduced, and might only occur under special circumstances. More information is needed before a thorough investigation can be made.

comment:4 Changed 10 years ago by olle

Traceability note:

  • Ticket #795 (Job table buttons may trigger erroneous table preferences update) concerns another problem related to table preferences for the job table.
  • Ticket #796 (Management of table preferences should be more stable) concerns an issue that may be the cause of the problem described in this ticket.
Last edited 9 years ago by olle (previous) (diff)

comment:5 Changed 10 years ago by olle

(In [4398]) Refs #796. Refs #795. Refs #783. Update of table preferences management:

  1. The table preferences pop-up window defined in public method Tag convert(org.proteios.gui.table.Table table) in class/file gui/web/GUIConverter.java in client/servlet/ is updated to not have a hidden input field with name "tableConfigurationUpdated" and value set to "true", but instead define an action link coupled to the "Apply" button, and adding parameter "tableConfigurationUpdated" with value "true" to this action link. The intention is to couple the setting of the flag more closely to the clicking of the "Apply" button in the table preferences pop-up window, and avoid any undesired side effects from having the value set in a hidden input field in the form.
  1. The fixes made in Ticket #795 (Job table buttons may trigger erroneous table preferences update) to class/file action/job/ListJobs.java in client/servlet/, where the value of valid parameter VString VTABLECONFIGURATIONUPDATED was explicitly set to "false", when one of the buttons for the job table was clicked, have been reverted, in order to check if the modification above makes management of table preferences more stable.

comment:6 Changed 9 years ago by olle

Resolution: fixed
Status: assignedclosed

Ticket closed as the update added in Ticket #796 (Management of table preferences should be more stable) hopefully will make table preferences work for the job table.

Note: See TracTickets for help on using tickets.