Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#184 closed defect (fixed)

Screenshot is empty

Reported by: Peter Johansson Owned by: Jari Häkkinen
Priority: critical Milestone: 0.6
Component: core Version: trunk
Keywords: Cc:

Change History (9)

comment:1 Changed 14 years ago by Jari Häkkinen

Status: newassigned

The problem is due to missing #include <cassert> as many times before.

Parser.cc: In constructor 'theplu::svndigest::Parser::Parser(const std::string&)': Parser.cc:42: error: 'assert' was not declared in this scope Parser.cc: In member function 'void theplu::svndigest::Parser::parse(std::istream&, std::vector<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::allocator<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > > >&)': Parser.cc:121: error: 'assert' was not declared in this scope make[2]: * [Parser.lo] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

comment:2 Changed 14 years ago by Jari Häkkinen

Resolution: fixed
Status: assignedclosed

(In [299]) Fixes #184.

comment:3 Changed 14 years ago by Jari Häkkinen

I am also getting

[...] Parsing /home/lev/jari/projects/pristine/svndigest/configure.ac Retrieving commit dates Removing old target tree: /scratch/lev/jari/tmp/svndigest/svndigest Generating output Segmentation fault

comment:4 Changed 14 years ago by Peter Johansson

Ok, that makes more sense because compilation error would not cause a new EMPTY output.

comment:5 in reply to:  3 Changed 14 years ago by Peter Johansson

Resolution: fixed
Status: closedreopened

Replying to jari:

I am also getting

[...] Parsing /home/lev/jari/projects/pristine/svndigest/configure.ac Retrieving commit dates Removing old target tree: /scratch/lev/jari/tmp/svndigest/svndigest Generating output Segmentation fault

The error should be in

print_main_page(tree.name(), local_log, stats);

function because there is no such output (index.html is empty) and svndigest is there which means

print_css("svndigest.css");

tow lines up works ok.

comment:6 Changed 14 years ago by Jari Häkkinen

Well, I spotted the problem. I'll checkin a solution but you'll have some work in Trac.cc

comment:7 Changed 14 years ago by Jari Häkkinen

Resolution: fixed
Status: reopenedclosed

(In [300]) Addresses #187 and fixes #184.

comment:8 Changed 14 years ago by Jari Häkkinen

Well I suppose that the core dump was there before the compilation error because the screenshot update script failed on compilation error. Whatever, the screenshot is created but a new ticket:184 was created to resolve the issues creating the core dump.

comment:9 Changed 14 years ago by Jari Häkkinen

I mean ticket:187

Note: See TracTickets for help on using tickets.