Opened 16 years ago

Closed 16 years ago

#3 closed defect (fixed)

date vector does not equal line vector

Reported by: Peter Johansson Owned by: Jari Häkkinen
Priority: critical Milestone: 0.1
Component: core Version: 0.1
Keywords: Cc:

Description (last modified by Peter Johansson)

vektorn som innehåller datumen (skapas i CommitStat?) och vektorn som innehåller radinformationen (skapas i Stats.accumulated()) är inte lika långa. Båda ska ha längden N+1 där N är senaste revision.

The problem is most likely that the date vector is generated incorrectly. It is generated parsing the 'svn blame -q' output. This does not yield the log to the revision we want. Rather we should specify the revision by calling 'svn log -r 1:HEAD -q'.

Change History (3)

comment:1 Changed 16 years ago by Peter Johansson

Milestone: v0.1
Priority: majorcritical

comment:2 Changed 16 years ago by Peter Johansson

Description: modified (diff)

comment:3 Changed 16 years ago by Peter Johansson

Resolution: fixed
Status: newclosed

fixed it by calling 'svn log -r 1:HEAD -q'.

Note: See TracTickets for help on using tickets.