Changes between Initial Version and Version 1 of Ticket #336


Ignore:
Timestamp:
Jun 5, 2008, 4:44:39 PM (13 years ago)
Author:
Peter Johansson
Comment:

fixed typo

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #336 – Description

    initial v1  
    88== Compatibility ==
    99
    10 Some issues regarding compatibility. The merge tracking requires that both client and server are of version 1.5 or later. If the client is older I guess the switch is just ignored.
     10Some issues regarding compatibility. The merge tracking requires that both client and server are of version 1.5 or later. If the server is older I guess the switch is just ignored.
    1111
    1212To incorporate this into svndigest we will need to use 1.5 API. Therefore it would be nice if we could check in `configure` which version we are compiling against, and then have PP macro say `HAVE_SVN_1_5` and use that to decide which API to call. This ambivalence should only occur in SVN singleton that is our connection to svn api. This means that user with svn 1.4 still can use svndigest, and user with svn 1.5 will get the expected functionality.