Opened 11 years ago

Closed 11 years ago

#417 closed defect (fixed)

bootstrap has no code in statistics

Reported by: Peter Johansson Owned by: Peter Johansson
Priority: minor Milestone: svndigest 0.7.1
Component: configuration Version: 0.7
Keywords: Cc:

Description

Here http://cbbp.thep.lu.se/~jari/svndigest/svndigest/blame_output/bootstrap.html all lines are considered either comment or empty.

We should change the configuration of svndigest, and it should probably be changed in the default setting too.

Change History (5)

comment:1 Changed 11 years ago by Peter Johansson

bootstrap existed in config file so this must be caused by something less obvious.

comment:2 Changed 11 years ago by Peter Johansson

Status: newassigned

comment:3 Changed 11 years ago by Peter Johansson

(In [925]) refs #417 extending tests of Configuration and using Suite class in test

comment:4 Changed 11 years ago by Peter Johansson

(In [926]) NOTE test repo in trunk is frozen until this has been merged into trunk. adding bootstrap file in test repo. refs #417.

comment:5 Changed 11 years ago by Peter Johansson

Resolution: fixed
Status: assignedclosed

(In [927]) Fixes #417.

File name in parsing rules are matched against the file name and not the entire path. This has no influence on most files because the name starts with a wild card (*) but for files not doing so (default bootstrap and Makefile) the correct parsing rule will be used. It is recommended to remove the cache of such files before running svndigest.

Note: See TracTickets for help on using tickets.