Opened 10 years ago

Closed 10 years ago

#487 closed defect (fixed)

No rule to make target `repo/db/current

Reported by: Peter Johansson Owned by: Peter Johansson
Priority: major Milestone: svndigest 0.9.1
Component: test Version: trunk
Keywords: Cc:

Description

When building from svndigest-0.9.tar.gz, make check fails with

g++ -pedantic -Wno-long-long -O3    -o cache_partial.test cache_partial.o ./libsvndigesttest.a ../lib/libsvndigest.a ../yat/libyat.a -lsvn_client-1 -lsvn_diff-1 -lsvn_wc-1 -lsvn_ra-1 -lsvn_subr-1  -lapr-1   -lpthread -lplplotcxxd -lplplotd -lltdl -ldl -lm -lcsirocsa -lcsironn -lqhull -lqsastime   
make[3]: *** No rule to make target `repo/db/current', needed by `cache_partial.log'.  Stop.

Change History (4)

comment:1 Changed 10 years ago by Peter Johansson

Interestingly, I cannot reproduce on Mac OSX. That explains why this was not caught during the ReleaseProcedure.

comment:2 Changed 10 years ago by Peter Johansson

(In [1311]) refs #487. Only depend on repo when we are in wc. Strictly speaking we could depend also when not in wc but have test repo, i.e., building from an svn export, but that corner case seemed less important and Automake Conditinal HAVE_SVN_WC was already available.

comment:3 Changed 10 years ago by Peter Johansson

Owner: changed from Jari Häkkinen to Peter Johansson
Status: newassigned

comment:4 Changed 10 years ago by Peter Johansson

Resolution: fixed
Status: assignedclosed

r1311 fixed the problem. distcheck now passes on the machine on which the problem was detected.

Note: See TracTickets for help on using tickets.