Ignore:
Timestamp:
May 21, 2008, 6:03:42 PM (13 years ago)
Author:
Peter
Message:

config.h is no longer installed. Therefore, do not include config.h
into other header files. Instead there is a yat/yat-config.h which
will be installed and can therefore be used in header files. The
yat-config contains the same information as config.h but variables are
prefix'd with a YAT_. I had to change style in version.m4 due to a
variable clash between variables set in version.m4 and variables I
wanted in config.h.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/build_support/version.m4

    r1307 r1319  
    2525#
    2626# MAJOR - Modify when incompatible changes are made
    27 m4_define([MAJOR_VERSION], [0])
     27m4_define([yat_major_version], [0])
    2828# MINOR - Modify when new functionality is added
    29 m4_define([MINOR_VERSION], [5])
     29m4_define([yat_minor_version], [5])
    3030# PATCH - Modify for every released patch
    31 m4_define([PATCH_VERSION], [0])
     31m4_define([yat_patch_version], [0])
    3232
    3333# DEV_BUILD - When rolling a tarball we set this to `false'. In
    3434# repository value remains `true'.
    35 m4_define([DEV_BUILD], [true])
     35m4_define([yat_dev_build], [true])
    3636
    3737# Library versioning (current:revision:age)
     
    5454# yat-0.4.1  1:0:0
    5555#
    56 m4_define([LT_VERSION], [1:0:0])
     56m4_define([yat_lt_version], [1:0:0])
    5757
    5858
     
    6262
    6363# Setting YAT_VERSION based upon settings above
    64 m4_define([YAT_VERSION],MAJOR_VERSION.MINOR_VERSION)
     64m4_define([yat_version],yat_major_version.yat_minor_version)
    6565# disregarding patch number if zero
    66 m4_define([YAT_VERSION], m4_if(PATCH_VERSION,[0], YAT_VERSION,
    67                                   YAT_VERSION.PATCH_VERSION))
    68 m4_define([YAT_VERSION], m4_if(DEV_BUILD,[true], YAT_VERSION[pre],
    69                                   YAT_VERSION))
     66m4_define([yat_version], m4_if(yat_patch_version,[0], yat_version,
     67                                  yat_version.yat_patch_version))
     68m4_define([yat_version], m4_if(yat_dev_build,[true], yat_version[pre],
     69                                  yat_version))
    7070
Note: See TracChangeset for help on using the changeset viewer.