Changeset 1328 for trunk/yat/utility


Ignore:
Timestamp:
May 24, 2008, 8:07:01 AM (13 years ago)
Author:
Peter
Message:

added missing docs

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/yat/utility/version.h.in

    r1321 r1328  
    3535  \see http://apr.apache.org/versioning.html
    3636*/
     37
     38/**
     39   MAJOR version
     40
     41   No compatibility is guarenteed between MAJOR versions.
     42 */
    3743#define YAT_MAJOR_VERSION @YAT_MAJOR_VERSION@
     44
     45/**
     46   MINOR version
     47
     48   Minor API changes that do not cause binary compatibility problems.
     49   Reset to 0 when upgrading YAT_MAJOR_VERSION
     50 */
    3851#define YAT_MINOR_VERSION @YAT_MINOR_VERSION@
     52
     53/**
     54   PATCH version
     55
     56   The Patch level never includes API changes, simply bug fixes.
     57   Reset to 0 when upgrading YAT_MINOR_VERSION
     58 */
    3959#define YAT_PATCH_VERSION @YAT_PATCH_VERSION@
     60
     61/**
     62   VERSION
     63
     64   The version of yat in string format
     65 */
    4066#define YAT_VERSION "@VERSION@"
     67
     68/**
     69   DEV_BUILD
     70
     71   Is set to true in releases
     72 */
    4173#define YAT_DEV_BUILD @YAT_DEV_BUILD@
    4274
Note: See TracChangeset for help on using the changeset viewer.