Changeset 1409


Ignore:
Timestamp:
Aug 14, 2008, 5:59:22 PM (13 years ago)
Author:
Peter
Message:

corrected bug in parsing of argument and added error msg when arg is not valid

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/build_support/yat-config.in

    r1408 r1409  
    117117    ;;
    118118    --atleast-version=*)
     119      optarg=`@ECHO@ "$1" | sed 's/--atleast-version=//'`
    119120      min_major=`@ECHO@ "$optarg" | sed 's/\([0-9]*\).*/\1/'`
    120121      if test "$optarg" = "$min_major"; then
     
    129130      fi
    130131      if test "$optarg" = "$min_patch"; then
     132        echo "yat-config: \`$optarg' is not a valid VERSION"
    131133        exit 255
    132134      fi
    133135      if !(test -n "$min_major" && test -n "$min_minor" \
    134136           && test -n "$min_patch"); then
     137        echo "yat-config: \`$optarg' is not a valid VERSION"
    135138        exit 255
    136139      fi
Note: See TracChangeset for help on using the changeset viewer.