Ignore:
Timestamp:
Sep 11, 2009, 5:04:35 AM (12 years ago)
Author:
Peter
Message:

deprecate constructors conditionally. Deprecation is active only for gcc and only for gcc older than 4.3. For 4.3 and newer the class deprecation should results in a warning. refs #521

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/yat/utility/OptionInFile.h

    r2057 r2058  
    5555    */
    5656    OptionInFile(CommandLine& cmd, std::string name, std::string desc,
    57                  bool required=false);
     57                 bool required=false) YAT_DEPRECATE_GCC_PRE4_3;
    5858
    5959    /**
Note: See TracChangeset for help on using the changeset viewer.