Changeset 2406


Ignore:
Timestamp:
Jan 12, 2011, 9:41:41 PM (11 years ago)
Author:
Peter
Message:

require automake 1.10 rather than just automake (skip test with old automake). fixes #650

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/test/common_defs.sh.in

    r2384 r2406  
    5757  for tool in $required; do
    5858    case $tool in
     59      automake)
     60      echo "$me: running $tool --version"
     61      ($tool --version) || exit 77;
     62      # skip test if automake older than v1.10
     63      version_am=`$tool --version | head -n 1 | cut -f 2 -d ')'`
     64      ver_major=`echo ${version_am} | cut -f 1 -d '.'`
     65      test ${ver_major} -ge 1 || exit 77
     66      ver_minor=`echo ${version_am} | cut -f 2 -d '.'`
     67      test ${ver_major} -gt 1 || test ${ver_minor} -ge 10 || exit 77
     68      ;;
    5969      libtool)
    6070      # GNU libtool comes as glibtool on Mac OS
Note: See TracChangeset for help on using the changeset viewer.