Changeset 2574


Ignore:
Timestamp:
Oct 3, 2011, 12:25:29 AM (10 years ago)
Author:
Peter
Message:

prefer evaluation at autoconf time. Add default value (0.5) in docs.

Location:
trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/doc/build_tool.doxygen

    r2564 r2574  
    7171
    7272\verbatim
    73    YAT_CHECK_YAT([minimum-version], [action-if-found], [action-if-not-found])
     73YAT_CHECK_YAT([minimum-version=0.5], [action-if-found], [action-if-not-found])
    7474\endverbatim
    7575
     
    8181
    8282\verbatim
    83    AC_MSG_FAILURE([could not find required version of yat])
     83AC_MSG_FAILURE([could not find required version of yat])
    8484\endverbatim
    8585
     
    9191
    9292\verbatim
    93    AM_CPPFLAGS = $(YAT_CPPFLAGS)
    94    AM_CXXFLAGS = $(YAT_CXXFLAGS)
    95    AM_LDFLAGS = $(YAT_LDFLAGS)
    96    LDADD = $(YAT_LIBS)
     93AM_CPPFLAGS = $(YAT_CPPFLAGS)
     94AM_CXXFLAGS = $(YAT_CXXFLAGS)
     95AM_LDFLAGS = $(YAT_LDFLAGS)
     96LDADD = $(YAT_LIBS)
    9797\endverbatim
    9898
  • trunk/m4/yat.m4

    r2451 r2574  
    5656#
    5757#
    58 #   YAT_CHECK_VERSION([MINIMUM-VERSION],[ACTION-IF-FOUND],[ACTION-IF-NOT-FOUND])
     58#   YAT_CHECK_VERSION([MINIMUM-VERSION=0.5],
     59#                     [ACTION-IF-FOUND],[ACTION-IF-NOT-FOUND])
    5960#
    6061#     If the version of yat is at least MINIMUM-VERSION, execute
     
    105106
    106107#
    107 # serial 5  # version number of yat.m4
     108# serial 6  # version number of yat.m4
    108109#
    109110# see http://www.gnu.org/software/automake/manual/automake.html#Serials
     
    174175  AC_REQUIRE([YAT_FIND_YAT])  dnl
    175176  if test "$yat_config" != "no"; then
    176     ac_yat_min_version=m4_default([$1], [0.5])
    177     AC_MSG_CHECKING(if version of yat is at least $ac_yat_min_version)
    178 
    179     if $yat_config --atleast-version=$ac_yat_min_version; then
     177    m4_pushdef([yat_min_version], [m4_default([$1], [0.5])]) dnl
     178    AC_MSG_CHECKING([if version of yat is at least yat_min_version])
     179
     180    if $yat_config --atleast-version=yat_min_version; then
    180181      AC_MSG_RESULT([yes])
    181182      ac_yat_version_ok=yes;
     
    185186      AC_MSG_WARN([
    186187       '$yat_config --version' returned $ac_yat_version,
    187         but the minimum required version is $ac_yat_min_version.])
     188        but the minimum required version is yat_min_version.])
    188189    fi
     190    m4_popdef([yat_min_version]) dnl
    189191  fi
    190192
Note: See TracChangeset for help on using the changeset viewer.