Changeset 2832


Ignore:
Timestamp:
Sep 14, 2012, 7:40:27 AM (9 years ago)
Author:
Peter
Message:

Preparing release 0.9

Location:
branches/0.9-stable
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • branches/0.9-stable/NEWS

    r2821 r2832  
    55yat A.B.x series from http://dev.thep.lu.se/yat/svn/branches/0.9-stable
    66
    7 version 0.9 (released NOT YET)
     7version 0.9 (released 14 September 2012)
    88  - utility::SmithWaterman is deprecated (ticket #706)
    99  - yat now depends on boost thread and system library (ticket #568 and #714)
    1010  - utility::SmartPtr was marked internal (see r2778)
    1111  - ssearch now takes parameter setting mismatch (r2792)
     12  - RNG class is not multithread safe (ticket #568)
     13  - The build system now uses a non-recursive Makefile (ticket #703)
    1214
    1315  A complete list of closed tickets can be found here [[br]]
  • branches/0.9-stable/m4/version.m4

    r2798 r2832  
    2626m4_include([m4/my_version.m4])
    2727
    28 MY_VERSION_early([0], [9], [0], [true])
     28MY_VERSION_early([0], [9], [0], [false])
    2929
    3030# Library versioning (current:revision:age)
     
    5555# yat-0.5.5  2:4:0
    5656# yat-0.5.6  2:5:0
    57 # yat-0.6.0  3:0:0
     57# yat-0.6    3:0:0
    5858# yat-0.6.1  3:1:0
    5959# yat-0.6.2  3:2:0
    6060# yat-0.6.3  3:3:0
    61 # yat-0.7.0  4:0:0
     61# yat-0.7    4:0:0
    6262# yat-0.7.1  4:1:0
    6363# yat-0.7.2  4:2:0
    6464# yat-0.7.3  4:3:0
    65 # yat-0.8.0  5:0:0
     65# yat-0.8    5:0:0
    6666# yat-0.8.1  5:1:0
    6767# yat-0.8.2  5:2:0
     68# yat-0.9    6:0:0
    6869#
    6970# *Accidently, the libtool number was not updated for yat 0.5
Note: See TracChangeset for help on using the changeset viewer.