Ignore:
Timestamp:
Apr 22, 2014, 11:56:17 AM (8 years ago)
Author:
Peter
Message:

avoid test code that won't compile with old boost.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/test/bam_pair_iterator.cc

    r3194 r3196  
    2727#include "yat/omic/BamWriteIterator.h"
    2828#endif
     29
     30#include <boost/version.hpp>
    2931
    3032#include <algorithm>
     
    7476  for (; piter!=pend; ++piter) {
    7577    result.push_back(*piter);
     78    // This code doesn't work with boost 1.48 (or older). See
     79    // https://svn.boost.org/trac/boost/ticket/5697 for details. It's
     80    // not obvious the fix was included in v1.49, but let's test here
     81    // and if it wasn't modify this test accordingly and update the
     82    // docs in 'yat/omic/BamPairIterator.h'.
     83#if BOOST_VERSION > 104800
    7684    result.back().first() = piter->first();
    7785    result.back().second() = piter->second();
     86#endif
    7887  }
    7988  // not really doing anything since we've already iterated through
Note: See TracChangeset for help on using the changeset viewer.