Ignore:
Timestamp:
Oct 24, 2015, 3:12:39 AM (6 years ago)
Author:
Peter
Message:

#define YAT_HAVE_LIBBAM when linking against libbam. refs #794

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/0.13-stable/configure.ac

    r3417 r3426  
    371371  ], [$LIBZ $user_LIBS], [$LIBZ], [YAT_STATIC_LIBS])
    372372
    373   # Check if htslib is available. If no check if samtools API is available
     373  # Check if htslib is available. If not, check if samtools API is available
    374374  YAT_CHECK_HTS([
    375375    AC_MSG_CHECKING([htslib])
     
    385385      AC_MSG_CHECKING([samtools API])
    386386      AC_MSG_RESULT([yes])
     387      AC_DEFINE([YAT_HAVE_LIBBAM], [1],
     388                [Define to 1 if yat is built against libbam])
     389
    387390      LIBS="$BAM_LIBS $LIBS"
    388391      # check if function bam_calend works. Result of this test can be
     
    398401  ])
    399402  AC_SUBST([HAVE_HTSLIB], [$have_hts])
    400 
    401   AC_DEFINE([YAT_HAVE_LIBBAM], [1],
    402             [Define to 1 if yat is built with bam support])
    403403
    404404  YAT_CHECK_LA_LIBS([
Note: See TracChangeset for help on using the changeset viewer.