Opened 15 years ago

Closed 15 years ago

#178 closed request (fixed)

MultiDimensionalWeighted and GSL

Reported by: Peter Owned by: Peter
Priority: major Milestone: yat 0.2
Component: regression Version: trunk
Keywords: Cc:

Description

One of the design criteria for weighted implementations is that passing unity weights should result in the same as the non-weighted counterpart. In MultiDimensionalWeighted (and thereby inherited to PolynomialWeighted) this leads to problem most likely because of GSL. It seems GSL has implemented the estimation of the parameter covariance matrix in a fashion not fullfilling the criterion above.

See here for GSL discussion http://www.mail-archive.com/bug-gsl@gnu.org/msg00093.html

Should we skip the criterion here and just follow GSL or should we try to hack around it?

needed for #161

Change History (3)

comment:1 Changed 15 years ago by Peter

I checked out GSL from cvs repoitory and the file in question was not changed since gsl-1.8, so using a updated version of GSL would not solve this issue.

I think I will copy the code from GSL (into MultiDimensionalWeighted?.cc) and add the estimation of s2 that is needed to calculate the covariance of the parameters in satisfying fashion.

comment:2 Changed 15 years ago by Peter

Status: newassigned

I realised, it might be possible that the only thing needed is to multiply covariance_ with an estimate of s2. This correction could be done after the call to the GSL function as s2 is trivial to estimate (more or less the weighted sum of squared residuals).

I try this and add a add a test checking that unity weights is equivalent to using the non-weighted version.

comment:3 Changed 15 years ago by Peter

Resolution: fixed
Status: assignedclosed

(In [739]) fixes #178 and removes a bug in MultiDimensional?

Note: See TracTickets for help on using tickets.