Opened 14 years ago

Closed 14 years ago

#244 closed request (fixed)

Iterators for 1D containers

Reported by: Peter Owned by: Peter
Priority: major Milestone: yat 0.4
Component: utility Version: trunk
Keywords: Cc:

Description

relates to ticket:210

We need Iterators for our 1D containers.

The interface should be pretty much like std::vector<double>::const_iterator. The constness is there because DataLookups? are by design const.

Namespace? I suggest this class belong in utility.

A straight forward way to implement this is to only hold a T and an size_t telling which element in T we are pointing to.

Change History (3)

comment:1 Changed 14 years ago by Peter

Owner: changed from Jari Häkkinen to Peter
Status: newassigned

comment:2 Changed 14 years ago by Peter

Component: buildutility

Initial checkin of Iterators in [880]. Classes need testing and docs.

comment:3 Changed 14 years ago by Peter

Resolution: fixed
Status: assignedclosed

Fixed in [881] [882] [883] and [884]

Note: See TracTickets for help on using tickets.