Opened 16 years ago

Closed 16 years ago

Last modified 15 years ago

#3 closed enhancement (wontfix)

Restrict access to vector and matrix internal GSL stuff

Reported by: Jari Häkkinen Owned by: Jari Häkkinen
Priority: major Milestone:
Component: gslapi Version:
Keywords: Cc:

Description

Maybe the gslapi interface should be changed so that internal GSL structure can only be accessed by gslapi classes (as friend to each other)? The current implementation has public member functions exposing internal GSL structure to everyone. A user of the gslapi should not need to be aware of GSL structures.

Change History (3)

comment:1 Changed 16 years ago by Jari Häkkinen

Status: newassigned

comment:2 Changed 16 years ago by Jari Häkkinen

Resolution: wontfix
Status: assignedclosed

Access to the internal GSL structures must be allowed since other classes must pass them to GSL functions. (See some of the regression classes for examples on this.)

comment:3 Changed 15 years ago by wwwrun

Milestone: new_matrix

Milestone new_matrix deleted

Note: See TracTickets for help on using tickets.