Opened 13 years ago

Closed 13 years ago

#352 closed enhancement (fixed)

modify FLAGS when configure option --with-gsl-prefix

Reported by: Peter Owned by: Peter
Priority: trivial Milestone: yat 0.5
Component: build Version: trunk
Keywords: Cc:

Description

The configure script has two options related to GSL

  --with-gsl-prefix=PFX   Prefix where GSL is installed (optional)
  --with-gsl-exec-prefix=PFX Exec prefix where GSL is installed (optional)

which may be useful if GSL is installed in a non-standard location, for example, ~/local/.

The problem is that the macro in gsl.m4 uses this information and appends CFLAGS and LDFLAGS appropriately when trying to compile and link, respectively, against GSL. After the test is done the GSL macro resets the flags so they behave like const variables. In summary, this means that the tests will pass through but yat will not compile unless appropriate FLAGS are set either when calling configure or make.

Change History (2)

comment:1 Changed 13 years ago by Peter

Milestone: yat 0.x+yat 0.5

comment:2 Changed 13 years ago by Peter

Resolution: fixed
Status: newclosed

fixed in [1327]

Note: See TracTickets for help on using tickets.