Opened 12 years ago

Closed 12 years ago

#548 closed defect (fixed)

make doc gets stuck in latex prompt

Reported by: Peter Owned by: Jari Häkkinen
Priority: major Milestone: yat 0.5.4
Component: documentation Version: 0.5.3
Keywords: Cc:

Description

make doc does not work for me. Well actually it is the latex part that wont work, but instead it gets stuck in a latex prompt:

...
See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.262 \end{document}
                    
? 

This per se is not severe because I can build the html docs (that I care about) via make html, but the annoying thing is that documentation_test.sh calls make doc and thus also gets stuck and here we get stuck blindly since all output is redirected to /dev/null.

limpar:~/projects/yat-0.5.x peter$ latex --version
pdfTeX 3.141592-1.40.3-2.2 (Web2C 7.5.6)
kpathsea version 3.5.6
Copyright 2007 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
Kpathsea is copyright 2007 Karl Berry and Olaf Weber.
There is NO warranty.  Redistribution of this software is
covered by the terms of both the pdfTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the pdfTeX source.
Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
Kpathsea written by Karl Berry, Olaf Weber, and others.

Compiled with libpng 1.2.35; using libpng 1.2.35
Compiled with zlib 1.2.3; using zlib 1.2.3
Compiled with xpdf version 3.01

Change History (17)

comment:1 Changed 12 years ago by Peter

Clarification:

cd doc && make latex-local works but it is cd doc && make dvi-local that is problematic, i.e., converting doxygen generated latex source into a dvi file.

comment:2 Changed 12 years ago by Peter

It works fine on GNU/Linux Fedora 8 using

> doxygen --version
1.5.6
> latex --version | head -n 2
pdfeTeX 3.141592-1.21a-2.2 (Web2C 7.5.4)
kpathsea version 3.5.4

comment:3 Changed 12 years ago by Jari Häkkinen

make check does not complete on my Mac OS X 10.5.7

> doxygen --version
1.5.8
> latex --version
pdfeTeX 3.141592-1.21a-2.2 (Web2C 7.5.4)
kpathsea version 3.5.4

comment:4 Changed 12 years ago by Peter

OK, so the common denominators for failure are Mac (I have 10.4) and doxygen 1.5.8. Likely this is a problem in doxygen 1.5.8 or in our syntax. We need to track down which of our files that is input here, to see if there is something wrong in our comments.

Is it possible to call latex in a portable way such that errors are ignored?

Note that make check in trunk is still fine because the docs test was changed to issue make doc in 0.5.4pre which is not yet merged in to trunk.

comment:5 in reply to:  4 ; Changed 12 years ago by Jari Häkkinen

Replying to peter:

OK, so the common denominators for failure are Mac (I have 10.4) and doxygen 1.5.8. Likely this is a problem in doxygen 1.5.8 or in our syntax. We need to track down which of our files that is input here, to see if there is something wrong in our comments.

I think the problem is in yat/utility/stl_utility.h but that is a fairly wild guess.

Note that make check in trunk is still fine because the docs test was changed to issue make doc in 0.5.4pre which is not yet merged in to trunk.

Well, make doc fails in the trunk so the problem is also in trunk.

comment:6 in reply to:  5 ; Changed 12 years ago by Jari Häkkinen

Replying to jari:

I think the problem is in yat/utility/stl_utility.h but that is a fairly wild guess.

Now I think it is yat/utility/SVD.h

comment:7 in reply to:  5 ; Changed 12 years ago by Peter

Replying to jari:

Replying to peter:

Note that make check in trunk is still fine because the docs test was changed to issue make doc in 0.5.4pre which is not yet merged in to trunk.

Well, make doc fails in the trunk so the problem is also in trunk.

I said make check is fine in trunk.

comment:8 in reply to:  6 ; Changed 12 years ago by Peter

Replying to jari:

Replying to jari:

I think the problem is in yat/utility/stl_utility.h but that is a fairly wild guess.

Now I think it is yat/utility/SVD.h

Yeah, I think you remembered before some problem with the enum.

comment:9 in reply to:  7 Changed 12 years ago by Jari Häkkinen

Replying to peter:

I said make check is fine in trunk.

Of course, I just wanted to clarify that the problem also exist in the trunk, not as annoying as in 0.5 though.

comment:10 in reply to:  8 Changed 12 years ago by Jari Häkkinen

Replying to peter:

Replying to jari:

Replying to jari:

I think the problem is in yat/utility/stl_utility.h but that is a fairly wild guess.

Now I think it is yat/utility/SVD.h

Yeah, I think you remembered before some problem with the enum.

Yes, the problem is

enum SVDalgorithm {
	GolubReinsch,
	ModifiedGolubReinsch,
	Jacobi
};

comment:11 Changed 12 years ago by Jari Häkkinen

And the problem is in doxygen. The new 1.5.9 relased May 23, 2009 claims to have fixed the issue:

id 567777: Fixed problem with latex output when using enums.

So, we have to wait for a newer doxygen in macports.

comment:12 in reply to:  11 Changed 12 years ago by Jari Häkkinen

Replying to jari:

And the problem is in doxygen. The new 1.5.9 relased May 23, 2009 ...

1.5.9 was released April 30, the web page I am citing was updated May 23!

comment:13 Changed 12 years ago by Peter

OK, I think we should increase the resolution of the configure test, enable htlm output when that is possible and enable other output when that is possible. Using doxygen 1.5.6 is fine so I think we should allow that, but ban 1.5.8 for latex generation.

Also I would like to turn off the prompt when experiencing latex errors (?)

comment:14 Changed 12 years ago by Peter

(In [1986]) refs #548. Added AM_CONDITIONALs in doc/Makefile.am that will be used to turn on/off doxygen generation in a more detailed fashion.

comment:15 Changed 12 years ago by Peter

(In [1987]) refs #548. Turn on generation of docs of different depending on which tools are found during configure. If doxygen 1.5.8 is detected only html is enabled.

comment:16 in reply to:  13 ; Changed 12 years ago by Peter

Replying to peter:

Also I would like to turn off the prompt when experiencing latex errors (?)

There is an option LATEX_BATCHMODE in doxygen configure file that seems to turn off the prompt. Is that something we want to use?

comment:17 in reply to:  16 Changed 12 years ago by Peter

Resolution: fixed
Status: newclosed

Replying to peter:

Replying to peter:

Also I would like to turn off the prompt when experiencing latex errors (?)

There is an option LATEX_BATCHMODE in doxygen configure file that seems to turn off the prompt. Is that something we want to use?

I tried batch mode a bit, and I dont like it. The batch is also turned on when created images of equations for the html output. When there is a syntax error, it can easily pass by instead of, as now, stopping with a clear error message.

Note: See TracTickets for help on using tickets.