Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#570 closed defect (fixed)

bootstrap fails after changeset:2083

Reported by: Jari Häkkinen Owned by: Jari Häkkinen
Priority: major Milestone: yat 0.6
Component: build Version: trunk
Keywords: Cc:

Description (last modified by Jari Häkkinen)

#> ./bootstrap 
/usr/bin/m4:configure.ac:174: ERROR: end of file in string
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: autom4te failed with exit status: 1
autoreconf: aclocal failed with exit status: 1

and

#> autoreconf --version
autoreconf (GNU Autoconf) 2.61

Change History (11)

comment:1 Changed 13 years ago by Jari Häkkinen

Description: modified (diff)

comment:2 Changed 13 years ago by Jari Häkkinen

(In [2084]) Addresses #570. Fixed typo but bootstrap problems persist.

comment:3 Changed 13 years ago by Jari Häkkinen

Description: modified (diff)

After changeset:2084 the output from bootstrap is

#> ./bootstrap 
You should update your `aclocal.m4' by running aclocal.
Putting files in AC_CONFIG_AUX_DIR, `autotools'.
configure:21522: error: possibly undefined macro: AS_ECHO
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure:21560: error: possibly undefined macro: AS_VAR_IF
autoreconf: /usr/bin/autoconf failed with exit status: 1

comment:4 Changed 13 years ago by Peter

The problem is that I'm using macros not available in autoconf 2.61. I tried with different versions of autoconf and AS_ECHO works with 2.62 (and later) and AS_VAR_IF works with 2.63 (and later).

In this case AS_VAR_IF simply calls AS_IF, so we can rewrite it using AS_IF instead. AS_ECHO can obviously be rewritten using echo with the downside that it is much less portable (according to autoconf manual).

So the question is whether we should replace both AS_ECHO and AS_VAR_IF of whether we should upgrade AC_REQUIRE?

My vote would go for upgrading to 2.62 and replacing AS_VAR_IF but I don't know how much work that involve for you, so let me know what you think...

comment:5 Changed 13 years ago by Jari Häkkinen

As always, the problem lies elsewhere. I'll have to ask MO to upgrade.

comment:6 Changed 13 years ago by Peter

so we stay with 2.61?

comment:7 Changed 13 years ago by Peter

(In [2086]) avoid using AS_ECHO and AS_VAR_IF which are not part of autoconf 2.61 interface

comment:8 Changed 13 years ago by Peter

Resolution: fixed
Status: newclosed

comment:9 in reply to:  6 Changed 13 years ago by Jari Häkkinen

Replying to peter:

so we stay with 2.61?

Well you fixed it already, I was hoping to get a new version of autoconf installed. If I get an upgrade then we can revert changeset:2086.

The AC_PREREQ(2.61) line in configure.ac should be bumped if we go for a later version.

comment:10 Changed 13 years ago by Jari Häkkinen

I know have 2.63 so we can reintroduce the changes if you want to.

comment:11 Changed 13 years ago by Peter

(In [2088]) reverting r2086. Autoconf 2.63 is now needed to bootstrap yat from svn checkout. bumping AC_PREREQ in configure.ac to reflect that. refs #570.

Note: See TracTickets for help on using tickets.