Opened 11 years ago

Closed 11 years ago

#624 closed request (fixed)

add concept check class for concept DataIterator

Reported by: Peter Owned by: Peter
Priority: minor Milestone: yat 0.7
Component: utility Version: trunk
Keywords: Cc:

Description

Similar to Container2D in yat/utility/concept_check.h

Change History (3)

comment:1 Changed 11 years ago by Peter

Status: newassigned

comment:2 Changed 11 years ago by Peter

(In [2263]) adding a class DataIteratorConcept? for concept data iterator. refs #624

comment:3 Changed 11 years ago by Peter

Resolution: fixed
Status: assignedclosed

There is already a class DataIterator? so the name became a bit long. If anyone has better ideas of naming or think we should add a concept namespace I'm open ears, but the namespace idea seems a bit too much...

Note: See TracTickets for help on using tickets.