Opened 11 years ago

Closed 11 years ago

#636 closed defect (fixed)

"make distclean; ./configure; make clean;" fails

Reported by: Peter Owned by: Peter
Priority: trivial Milestone: yat 0.7
Component: build Version: trunk
Keywords: Cc:

Description

The error message is as below

configure:  Now type 'make && make check'.
Making clean in doc
make[1]: Entering directory `/home/peter/projects/yat/doc'
Makefile:450: ../yat/classifier/doxygen.mk: No such file or directory
Makefile:451: ../yat/normalizer/doxygen.mk: No such file or directory
Makefile:452: ../yat/random/doxygen.mk: No such file or directory
Makefile:453: ../yat/regression/doxygen.mk: No such file or directory
Makefile:454: ../yat/statistics/doxygen.mk: No such file or directory
Makefile:455: ../yat/utility/doxygen.mk: No such file or directory
make[1]: *** No rule to make target `../yat/utility/doxygen.mk'.  Stop.
make[1]: Leaving directory `/home/peter/projects/yat/doc'
make: *** [clean-recursive] Error 1

The reason is obviously that the doxygen.mk files are not created.

Perhaps we should distribute these files remove them under maintainer-clean (rather than distclean) or if we could have configure create the files (at the end of configuration) similarily to how the .deps/*Po files are created.

Change History (2)

comment:1 Changed 11 years ago by Peter

Milestone: yat 0.x+yat 0.7
Status: newassigned

comment:2 Changed 11 years ago by Peter

Resolution: fixed
Status: assignedclosed

(In [2308]) creating dummie doxygen.mk during configure. fixes #636

Note: See TracTickets for help on using tickets.