Opened 11 years ago

Closed 11 years ago

#642 closed defect (invalid)

warnings from autoconf 2.68

Reported by: Peter Owned by: Peter
Priority: trivial Milestone:
Component: build Version: trunk
Keywords: Cc:

Description

configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:4207: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5339: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:4207: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5339: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:5424: _LT_LANG_CXX_CONFIG is expanded from...
m4/libtool.m4:816: _LT_LANG is expanded from...
m4/libtool.m4:799: LT_LANG is expanded from...
m4/libtool.m4:827: _LT_LANG_DEFAULT_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:4207: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5339: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:4207: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5339: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:5424: _LT_LANG_CXX_CONFIG is expanded from...
m4/libtool.m4:816: _LT_LANG is expanded from...
m4/libtool.m4:799: LT_LANG is expanded from...
m4/libtool.m4:827: _LT_LANG_DEFAULT_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:4207: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5339: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:4207: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5339: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:5424: _LT_LANG_CXX_CONFIG is expanded from...
m4/libtool.m4:816: _LT_LANG is expanded from...
m4/libtool.m4:799: LT_LANG is expanded from...
m4/libtool.m4:827: _LT_LANG_DEFAULT_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:4207: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5339: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:4207: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5339: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:5424: _LT_LANG_CXX_CONFIG is expanded from...
m4/libtool.m4:816: _LT_LANG is expanded from...
m4/libtool.m4:799: LT_LANG is expanded from...
m4/libtool.m4:827: _LT_LANG_DEFAULT_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:4207: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5339: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:4207: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5339: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level
configure.ac:83: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:5424: _LT_LANG_CXX_CONFIG is expanded from...
m4/libtool.m4:816: _LT_LANG is expanded from...
m4/libtool.m4:799: LT_LANG is expanded from...
m4/libtool.m4:827: _LT_LANG_DEFAULT_CONFIG is expanded from...
m4/libtool.m4:143: _LT_SETUP is expanded from...
m4/libtool.m4:69: LT_INIT is expanded from...
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
configure.ac:83: the top level

and configure.ac:83 is

AC_PROG_LIBTOOL

so my guess is that it some problem between libtool and autoconf

Change History (2)

comment:1 Changed 11 years ago by Peter

According to this thread, the problem is fixed in Libtool 2.4

http://lists.gnu.org/archive/html/autoconf/2010-09/msg00075.html

comment:2 Changed 11 years ago by Peter

Milestone: yat 0.x+
Resolution: invalid
Status: newclosed

Indeed, the problem vanishes with libtool 2.4

Note: See TracTickets for help on using tickets.