Opened 10 years ago

Closed 10 years ago

#663 closed enhancement (fixed)

boostrap silence error messages

Reported by: Peter Owned by: Peter
Priority: major Milestone: yat 0.7.2
Component: build Version: 0.7.1
Keywords: Cc:

Description

I tried running bootstrap with a too old Autoconf

$ ./bootstrap

which looks good, but no configure was created and if I try

$ ./bootstrap || echo $?
63

the exit value 63 indicates too old tool. If I try

$ ./bootstrap --verbose
bootstrap: running: autoreconf --install --symlink --force --verbose
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4
configure.ac:38: error: Autoconf version 2.63 or higher is required
configure.ac:38: the top level
autom4te: /opt/local/bin/gm4 failed with exit status: 63
aclocal: /opt/local/bin/autom4te failed with exit status: 63
autoreconf: aclocal failed with exit status: 63

The bottom line is: I wanna see error message also when running without --verbose.

Change History (1)

comment:1 Changed 10 years ago by Peter

Resolution: fixed
Status: newclosed

(In [2461]) fixes #663. Avoid silencing stderr.

Note: See TracTickets for help on using tickets.