Opened 10 years ago

Closed 10 years ago

#676 closed defect (worksforme)

undefined symbol in GFF2

Reported by: Peter Owned by: Peter
Priority: major Milestone:
Component: omic Version: trunk
Keywords: Cc:

Description

Got this linker error:

Undefined symbols:
  "vtable for theplu::yat::omic::GFF2", referenced from:
      theplu::yat::omic::GFF2::GFF2()in cc6T2GEC.o
      theplu::yat::omic::GFF2::~GFF2()in cc6T2GEC.o
  "theplu::yat::omic::getline(std::basic_istream<char, std::char_traits<char> >&, theplu::yat::omic::GFF&)", referenced from:
      _main in cc6T2GEC.o
  "theplu::yat::omic::GFF::GFF()", referenced from:
      theplu::yat::omic::GFF2::GFF2()in cc6T2GEC.o
  "theplu::yat::omic::GFF::~GFF()", referenced from:
      theplu::yat::omic::GFF2::~GFF2()in cc6T2GEC.o
ld: symbol(s) not found
collect2: ld returned 1 exit status

Change History (2)

comment:1 Changed 10 years ago by Peter

Status: newassigned

comment:2 Changed 10 years ago by Peter

Milestone: yat 0.8
Resolution: worksforme
Status: assignedclosed

Can't reproduce this and there is a test creating a GFF object so the report seems to be nonsense.

Note: See TracTickets for help on using tickets.