Opened 10 years ago

Closed 10 years ago

#681 closed defect (fixed)

Missing deprecated list

Reported by: Peter Owned by: Peter
Priority: minor Milestone: yat 0.8
Component: documentation Version: trunk
Keywords: Cc:

Description

In my local docs generated with doxygen 1.7.5.1 I have deprecated list which I don't see in the docs here, http://cbbp.thep.lu.se/~jari/documents/yat-0.8.x/pages.html

I think it should be possible to tweak so also older doxygen will generate the list. I suspect the bad boy here is the YAT_DEPRECATED.

Change History (15)

comment:1 Changed 10 years ago by Peter

Summary: Mising deprecated listMissing deprecated list

comment:2 Changed 10 years ago by Peter

I just downgraded to doxygen 1.5.8 and then it works. I see a link to Deprecated List. thep.lu.se runs doxygen 1.5.9 so will try that next.

comment:3 Changed 10 years ago by Peter

What!!? I built from https://doxygen.svn.sourceforge.net/svnroot/doxygen/tags/Release_1_5_9 and that gave me a binary that says doxygen --version 1.5.8. Confusing!

comment:4 Changed 10 years ago by Jari Häkkinen

We could try to get our docs host to upgrade doxygen?

comment:5 Changed 10 years ago by Peter

Status: newassigned

Yes, perhaps. I'm curious what the problem is though, so debugging on host system now.

comment:6 Changed 10 years ago by Peter

OK, this is fishy. I noticed the problem is not in trunk on host. Also I can not reproduce in 0.8-stable using william at thep. Can you please rerun 0.8-stable?

comment:7 Changed 10 years ago by Jari Häkkinen

Will do, but I am running on bob.

comment:8 Changed 10 years ago by Peter

It works on bob as well (for me).

comment:9 Changed 10 years ago by Peter

I noticed that your yat/*/doxygen.mk are not created properly. How do you generate the docs?

comment:10 Changed 10 years ago by Jari Häkkinen

I have redone docs for 0.7, 0.8, and trunk. trunk seems to be ok but not the two others. During the tests tonight I do make doc. Normally it is done with a Makefile:

svn update yat-0.8.x && \
	svn info yat-0.8.x | grep '^Last Changed Rev:' > yat-0.8.x/svn-time-stamp-t && \
	svndigest/trunk/build_support/move-if-change yat-0.8.x/svn-time-stamp-t yat-0.8.x/svn-time-stamp
( cd yat-0.8.x ; \
	  ./bootstrap && \
	  ./configure CXX=/usr/bin/g++ LD=/usr/bin/g++ && \
	  make doc )

comment:11 Changed 10 years ago by Peter

I can reproduce the problem if I mess up files doxygen.mk and I could resolve by doing

$ (cd doc && make clean)
$ rm yat/*/dx-stamp
$ make doc

The problem is that doxygen.mk is created in two places. First during configure a dummie version is created and then during make the real version is created. The reason for the dummie version to be generated is that doc/Makefile includes these files so without the dummie file that Makefile is broken. Before the when there was no dummie version generated one could not do for example

make distclean
./configure
make clean

There is a time stamp file to trigger the real generation of doxygen.mk and somehow you ended up in a situation when this rule was never triggered. I don't understand how you managed to end up there. It should be possible to improve this so we can avoid this dead end. Easiest would be to remove dx-stamp during bootstrap or perhaps improve the semantics in configure or the Makefile rule.

comment:12 Changed 10 years ago by Peter

(In [2620]) avoid problem with tied time-stamps in creation of doxygen.mk. refs #681

comment:13 Changed 10 years ago by Jari Häkkinen

I don't know how I ended up there either. I generated the docs on a pristine fresh checkout of the 0.8 stable branch. Also, the 0.7 branch is messed up to so the fix should probably be applied there too.

The 0.8 docs looks ok now.

comment:14 Changed 10 years ago by Peter

OK, I'll apply the patch in 0.7-stable too, and then I'll close this ticket.

Perhaps your computer is too fast for your file system or time stamps got skewed when working over NFS. Just speculating.

comment:15 Changed 10 years ago by Peter

Resolution: fixed
Status: assignedclosed

(In [2621]) backporting changeset [2620] to 0.7-stable branch. closes #681

Note: See TracTickets for help on using tickets.