Opened 9 years ago

Closed 9 years ago

#713 closed defect (fixed)

gcc 4.0.1 complains about -pthread

Reported by: Peter Owned by: Peter
Priority: trivial Milestone: yat 0.9
Component: build Version: trunk
Keywords: Cc:

Description

I get this for every compilation (OSX4)

  CXX      yat/statistics/Pearson.lo
i686-apple-darwin8-g++-4.0.1: unrecognized option '-pthread'

Change History (4)

comment:1 Changed 9 years ago by Peter

With gcc-mp-4.3 and gcc-mp-4.4 (built via mac port) I get no warnings.

comment:2 Changed 9 years ago by Peter

All tests pass with gcc 4.0, so the problem is not functional. But it is still ugly, so we should try to turn off -pthread when CXX does not understand it. Currently we only check that compiler does not error out...

comment:3 Changed 9 years ago by Peter

Seen on the web a couple of comments claiming the option is not needed on OS X because it (thread safety) is turned on by default.

http://lists.apple.com/archives/unix-porting/2005/Mar/msg00019.html

Perhaps we should just get rid of the option on OSX.

comment:4 Changed 9 years ago by Peter

Resolution: fixed
Status: newclosed

(In [2780]) exclude -pthread from CPPFLAGS if compiler is warning about it. closes #713

Note: See TracTickets for help on using tickets.