Opened 9 years ago

Closed 9 years ago

#719 closed defect (fixed)

configure silently accepts missing boost libs

Reported by: Peter Owned by: Peter
Priority: major Milestone: yat 0.9
Component: build Version: trunk
Keywords: Cc:

Description

BOOST_SYSTEM_LIB is set to empty string and configure runs through as though everything is OK. 'make all' works fine too, but 'make check' goes ballistic as several tests can't link and shell tests fail as well for the same reason.

This is on a CentOS5 system where I have boost 1.33 installed in /usr/include and /usr/lib64 and boost 1.41 header files installed in $HOME/local/include. This does not suffice and should be caught already at configure time.

This is with branches/0.9-stable but the problem is most likely in trunk as well (as they are still almost identical).

Change History (2)

comment:1 Changed 9 years ago by Peter

The problem is that boost macros are compilation based and do no linking. I suggest we add a link test after ax_boost_* (until this has been fixed upstream).

comment:2 Changed 9 years ago by Peter

Resolution: fixed
Status: newclosed

(In [2830]) add link tests with boost. closes #719

Note: See TracTickets for help on using tickets.